Opened 2 months ago

Last modified 2 months ago

#24685 reopened defect

Lockpad icon doesn't appear and connection is labeled as insecure when loading a PDF from a secure URL

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This doesn't happen all the time but it does sometimes, try to reproduce it by opening for example:

https://svn.torproject.org/svn/projects/design-paper/blocking.pdf

Child Tickets

Change History (5)

comment:1 Changed 2 months ago by cypherpunks

Fun, fun, it doesn't want to go to ​https://svn.torproject.org (if you paste it into the URL bar)

comment:2 in reply to:  1 ; Changed 2 months ago by cypherpunks

Replying to cypherpunks:

Fun, fun, it doesn't want to go to ​https://svn.torproject.org (if you paste it into the URL bar)

That's because there's an invisible character before the https:// that is put by trac, which leads to a direct search. Ok, fine, here you go for the plaintxt: https://svn.torproject.org/svn/projects/design-paper/blocking.pdf

comment:3 in reply to:  2 Changed 2 months ago by cypherpunks

Replying to cypherpunks:

Replying to cypherpunks:

Fun, fun, it doesn't want to go to ​https://svn.torproject.org (if you paste it into the URL bar)

That's because there's an invisible character before the https:// that is put by trac, which leads to a direct search. Ok, fine, here you go for the plaintxt: https://svn.torproject.org/svn/projects/design-paper/blocking.pdf

Damn trac! I tried to select carefully a part of that URL, but it copied that shit anyway!
BTW, I can confirm the described issue.

comment:4 Changed 2 months ago by cypherpunks

Resolution: duplicate
Status: newclosed

Duplicate of #20326.

comment:5 in reply to:  4 Changed 2 months ago by cypherpunks

Resolution: duplicate
Status: closedreopened

Replying to cypherpunks:

Duplicate of #20326.

Not necessarily the same thing, this one relates to when pdf.js gets triggered only.

Note: See TracTickets for help on using tickets.