#24751 closed defect (not a bug)

Circuit isn't refreshed across two same tabs witht the same FP domains

Reported by: vondjik Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Open two tabs with both: https://en.wikipedia.org/wiki/Main_Page

Go to tab 1 and click on new circuit.

Circuit for tab 1 as displayed in Torbutton is different from the circuit for tab 2 as displayed in Torbutton, meaning that it doesn't get refreshed.

Child Tickets

Change History (3)

comment:1 Changed 11 months ago by Dbryrtfbcbhgf

Correction. I'm not an expert on the torbutton, lets see what gk says.

Last edited 11 months ago by Dbryrtfbcbhgf (previous) (diff)

comment:2 in reply to:  1 Changed 11 months ago by vondjik

Replying to Dbryrtfbcbhgf:

Once the 2nd tab is manually refreshed the new circuit is used. If it auto refreshed all other tabs some users may lose information.

You're assuming that the only way that Torbutton can get refresh its information is that the tab should be refreshed, that's not the case as far as I'm aware.

comment:3 Changed 10 months ago by gk

Resolution: not a bug
Status: newclosed

The circuit display says which circuit got used to load the webpage. If you are on tab1 and reload it using a new circuit it's not surprising that the same webpage in tab2 shows the old circuit information (unless it has some dynamic elements that reload at least parts of the website).

I am not a fan of automatically reloading all the respective tabs in case they share the domain of the webpage in the focused tab which got reloaded over a new circuit.

Thus, I think this is working as expected. If you think we should reword things to make this more obvious feel free to reopen the ticket (suggestions are welcome!).

Note: See TracTickets for help on using tickets.