Opened 2 years ago

Closed 2 years ago

Last modified 22 months ago

#24764 closed defect (duplicate)

OSX 10.13.2 (17C88) - Instant crash on startup

Reported by: thomasd3 Owned by: tbb-team
Priority: Very High Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.2.7-rc
Severity: Critical Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

With the latest torbrowser, I get an instant crash as soon as it starts.

There is nothing in the log.

I did the usual uninstall / wipe data files / reinstall / reboot / etc.

When I start the browser, I get this error in the console, from EmojiFunctionRowIM_Extension:

<NSXPCConnection: 0x60c000105850> connection from pid 5063: Exception caught during decoding of received message, dropping incoming message.
Exception: Exception while decoding argument 0 (#2 of invocation):
<NSInvocation: 0x60400007d040>
return value: {v} void
target: {@} 0x0
selector: {:} null
argument 2: {{?=d@@@@{CGRect={CGPoint=dd}{CGSize=dd}}ccc@@@Ic}} <00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000>
argument 3: {@?} 0x0 (block)

Exception: decodeObjectForKey: class "TitlebarAndBackgroundColor" not loaded or does not exist

I do not know if this is what is bringing the browser down, but I only see that error when I try to launch the browser.

I tried to disable the emoji touchbar service, which created some unrelated odd problems, but that didn't change anything.

Child Tickets

Attachments (1)

instant crash.gif (509.5 KB) - added by thomasd3 2 years ago.
Video

Download all attachments as: .zip

Change History (25)

comment:1 Changed 2 years ago by Dbryrtfbcbhgf

Download and drag the alpha browser into a new folder on the desktop, open it and see if it crashes.
https://dist.torproject.org/torbrowser/7.5a10/TorBrowser-7.5a10-osx64_en-US.dmg

remember Do Not install any add-ons into TorBrowser.
https://www.torproject.org/docs/faq.html.en#TBBOtherExtensions

If that does not fix the issue, enable debug logging.

  1. Click on the TorBrowser-Data folder and go to TorBrowser-Data/Tor/torrc
  2. open the torrc and add Log debug file /path/to/log/tor_debug.log "choose your log save location"
  1. Open tor browser after you saved the torrc file and when it crashes post the log in this ticket.
Last edited 2 years ago by Dbryrtfbcbhgf (previous) (diff)

comment:2 Changed 2 years ago by Dbryrtfbcbhgf

Severity: BlockerMajor

Changed 2 years ago by thomasd3

Attachment: instant crash.gif added

Video

comment:3 Changed 2 years ago by thomasd3

I did edit the file:

[thomas:~/Library/Application Support/TorBrowser-Data/Tor] $ cat torrc
Log debug file ~/torlog/log.txt

but after crash, no log at all:

[thomas:~/Library/Application Support/TorBrowser-Data/Tor] $ ls ~/torlog/
[thomas:~/Library/Application Support/TorBrowser-Data/Tor] $

As you can see in the animated gif, the crash is really instant.

comment:4 Changed 2 years ago by thomasd3

Here is a screenshot from the console: https://imgur.com/a/67dbb

It shows a crash related to the touchbar on the macbook pro.
It is the same error coming up every time I launch Tor.

I ran the same version of Tor on my other mac, which doesn't have the touch bar, and it works without any problem.

It looks like Firefox is looking for a class called 'TitlebarAndBackgroundColor', in the emoji toolbar service, which doesn't exist; I'm with High Sierra, all up to date.

comment:5 in reply to:  4 Changed 2 years ago by Dbryrtfbcbhgf

Replying to thomasd3:

Here is a screenshot from the console: https://imgur.com/a/67dbb

It shows a crash related to the touchbar on the macbook pro.
It is the same error coming up every time I launch Tor.

I ran the same version of Tor on my other mac, which doesn't have the touch bar, and it works without any problem.

It looks like Firefox is looking for a class called 'TitlebarAndBackgroundColor', in the emoji toolbar service, which doesn't exist; I'm with >High Sierra, all up to date.

1.Restart your Mac because you said that you I tried to disable the emoji touchbar service , just to make sure the Touch Bar service is enabled.

2.Download https://www.mozilla.org/en-US/firefox/new/?scene=2 and run it, if it does not crash follow the directions below.

3.You should only need to run the following commands in a Terminal window to use mozregression:

sudo easy_install pip
sudo pip2 install -U mozregression
mozregression --find-fix --good 57 --bad 52

4.A number of Firefox versions will open in succession to narrow down when this was fixed. Simply type good or bad in Terminal based on whether or not a build reproduces the bug.

5.This should take a few minutes or more, after your finished post all the results into this ticket.

http://mozilla.github.io/mozregression/
Credit for directions https://bugzilla.mozilla.org/user_profile?user_id=456485

Last edited 2 years ago by Dbryrtfbcbhgf (previous) (diff)

comment:6 Changed 2 years ago by Dbryrtfbcbhgf

Status: newneeds_information

comment:7 Changed 2 years ago by Dbryrtfbcbhgf

Priority: MediumVery High

comment:8 Changed 2 years ago by Dbryrtfbcbhgf

Severity: MajorCritical

comment:9 Changed 2 years ago by thomasd3

Here's the output:

[thomas:~] $ mozregression --find-fix --good 57 --bad 52

0:00.43 INFO: Using date 2016-11-14 for release 52
0:00.43 INFO: Using date 2017-09-21 for release 57
0:05.33 INFO: Testing good and bad builds to ensure that they are really good and bad...
0:05.33 INFO: Downloading build from: https://archive.mozilla.org/pub/firefox/nightly/2017/09/2017-09-21-22-02-43-mozilla-central/firefox-58.0a1.en-US.mac.dmg

Downloaded 100%

0:45.64 INFO: Running mozilla-central build for 2017-09-21
1:04.17 INFO: Launching /private/var/folders/1y/2wcx2c056m9d591zqdyv50mw0000gn/T/tmpFnnIWX/FirefoxNightly.app/Contents/MacOS/firefox
1:04.17 INFO: Application command: /private/var/folders/1y/2wcx2c056m9d591zqdyv50mw0000gn/T/tmpFnnIWX/FirefoxNightly.app/Contents/MacOS/firefox -foreground -profile /var/folders/1y/2wcx2c056m9d591zqdyv50mw0000gn/T/tmpa7clOn.mozrunner
1:04.19 INFO: application_buildid: 20170921220243
1:04.19 INFO: application_changeset: ca7d18dbacbf103d74a3213d8d08a7c3e4def9a2
1:04.19 INFO: application_name: Firefox
1:04.19 INFO: application_repository: https://hg.mozilla.org/mozilla-central
1:04.19 INFO: application_version: 58.0a1

Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry' or 'exit' and press Enter): good

1:27.77 INFO: Using local file: /var/folders/1y/2wcx2c056m9d591zqdyv50mw0000gn/T/tmp6p5Cjt/2016-11-14--mozilla-central--firefox-53.0a1.en-US.mac.dmg (downloaded in background)
1:27.77 INFO: Running mozilla-central build for 2016-11-14
1:55.47 INFO: Launching /private/var/folders/1y/2wcx2c056m9d591zqdyv50mw0000gn/T/tmpLeOwSK/FirefoxNightly.app/Contents/MacOS/firefox
1:55.47 INFO: Application command: /private/var/folders/1y/2wcx2c056m9d591zqdyv50mw0000gn/T/tmpLeOwSK/FirefoxNightly.app/Contents/MacOS/firefox -foreground -profile /var/folders/1y/2wcx2c056m9d591zqdyv50mw0000gn/T/tmpHQh_Jc.mozrunner
1:55.49 INFO: application_buildid: 20161114043454
1:55.49 INFO: application_changeset: a516c754042c438a5c1499171ca525a980ecb911
1:55.49 INFO: application_name: Firefox
1:55.49 INFO: application_repository: https://hg.mozilla.org/mozilla-central
1:55.49 INFO: application_version: 53.0a1

Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry' or 'exit' and press Enter): good

2:12.66 ERROR: Build was expected to be bad! The initial good/bad range seems incorrect.


I want to point out that I've been using Firefox for many years and all versions do work on my machine.

comment:10 Changed 2 years ago by thomasd3

Here you can see what process crashes:

[thomas:~] $ sudo execsnoop -v
STRTIME UID PID PPID ARGS
2018 Jan 1 05:12:23 0 7366 1 xpcproxy
2018 Jan 1 05:12:23 501 7366 1 firefox
2018 Jan 1 05:12:23 501 7367 7366 sh
2018 Jan 1 05:12:23 501 7368 7367 dirname
2018 Jan 1 05:12:23 501 7367 7366 tor.real

It seems to hang at tor.real

comment:11 Changed 2 years ago by thomasd3

Here we can clearly see the error:

[thomas:/Applications] $ cat ~/test
(version 1)
(allow default)

[thomas:/Applications] $ sandbox-exec -f ~/test TorBrowser.app/Contents/MacOS/firefox
Jan 01 05:19:57.444 [notice] Tor 0.3.2.7-rc running on Darwin with Libevent 2.0.22-stable, OpenSSL 1.0.2n, Zlib 1.2.11, Liblzma N/A, and Libzstd N/A.
Jan 01 05:19:57.444 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jan 01 05:19:57.444 [notice] Read configuration file "/Applications/TorBrowser.app/Contents/Resources/TorBrowser/Tor/torrc-defaults".
Jan 01 05:19:57.444 [notice] Read configuration file "/Users/thomas/Library/Application Support/TorBrowser-Data/Tor/torrc".
Jan 01 05:19:57.447 [warn] Couldn't set maximum number of file descriptors: Invalid argument
Jan 01 05:19:57.447 [warn] Failed to parse/validate config: Problem with ConnLimit value. See logs for details.
Jan 01 05:19:57.447 [err] Reading config failed--see warnings above.
1514780397600 addons.webextension.{73a6fe31-595d-460b-a920-fcc0f8843232} WARN Loading extension '{73a6fe31-595d-460b-a920-fcc0f8843232}': Reading manifest: Error processing permissions.1: Unknown permission "privacy"
1514780397600 addons.webextension.{73a6fe31-595d-460b-a920-fcc0f8843232} WARN Loading extension '{73a6fe31-595d-460b-a920-fcc0f8843232}': Reading manifest: Error processing permissions.4: Unknown permission "unlimitedStorage"
1514780397600 addons.webextension.https-everywhere-eff@… WARN Loading extension 'https-everywhere-eff@…': Reading manifest: Error processing devtools_page: An unexpected property was found in the WebExtension manifest.
1514780397700 addons.webextension.https-everywhere-eff@… WARN Please specify whether you want browser_style or not in your browser_action options.
Illegal AddressMatcher: [xpconnect wrapped nsIPrefBranch] -- TypeError: s.split is not a function
Illegal AddressMatcher: [xpconnect wrapped nsIPrefBranch] -- TypeError: s.split is not a function
2018-01-01 05:20:43.368 firefox[7480:751136] IMKInputSession [0x7fd82cc99cd0 presentFunctionRowItemTextInputViewWithEndpoint:completionHandler:] : [self textInputContext]=0x7fd8333d9bf0 *NO* NSRemoteViewController to client, NSError=Error Domain=NSCocoaErrorDomain Code=4097 "connection from pid 0" UserInfo={NSDebugDescription=connection from pid 0}, com.apple.inputmethod.EmojiFunctionRowItem
2018-01-01 05:20:49.185 firefox[7480:751136] IMKInputSession [0x7fd83315f7e0 presentFunctionRowItemTextInputViewWithEndpoint:completionHandler:] : [self textInputContext]=0x7fd8333d9bf0 *NO* NSRemoteViewController to client, NSError=Error Domain=NSCocoaErrorDomain Code=4097 "connection from pid 0" UserInfo={NSDebugDescription=connection from pid 0}, com.apple.inputmethod.EmojiFunctionRowItem

It goes back to com.apple.inputmethod.EmojiFunctionRowItem

comment:12 Changed 2 years ago by thomasd3

Other people seem to have a problem with this with other software: https://discussions.apple.com/thread/7960044

comment:13 in reply to:  12 Changed 2 years ago by Dbryrtfbcbhgf

Replying to thomasd3:

Other people seem to have a problem with this with other software: https://discussions.apple.com/thread/7960044

  1. Download the attachment and extract it on your desktop and run tor, see if it crashes. Post results

https://www.icloud.com/iclouddrive/09DWOETq9AXoiXQ9Av-43gEsw#Tor

  1. Does Firefox 57 cause Touch Bar errors?

The apps that are crashing are the ones that do not support the Touch Bar.

gk should be back on January 1 or 2, and should be able to fix the issue.

Last edited 2 years ago by Dbryrtfbcbhgf (previous) (diff)

comment:14 Changed 2 years ago by thomasd3

[thomas:~/Downloads/Tor] $ ./tor
Jan 01 16:47:14.630 [notice] Tor 0.3.2.7-rc running on Darwin with Libevent 2.0.22-stable, OpenSSL 1.0.2n, Zlib 1.2.11, Liblzma N/A, and Libzstd N/A.
Jan 01 16:47:14.631 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jan 01 16:47:14.631 [notice] Configuration file "/var/tmp/dist/tor/etc/tor/torrc" not present, using reasonable defaults.
Jan 01 16:47:14.634 [warn] Couldn't set maximum number of file descriptors: Invalid argument
Jan 01 16:47:14.634 [warn] Failed to parse/validate config: Problem with ConnLimit value. See logs for details.
Jan 01 16:47:14.634 [err] Reading config failed--see warnings above.

It doesn't start, I get this error right away.

I tried this too:

[thomas:~/Downloads/Tor] $ mkdir /var/tmp/dist/tor/etc/tor
[thomas:~/Downloads/Tor] $ cp /usr/local/etc/tor/torrc /var/tmp/dist/tor/etc/tor/
[thomas:~/Downloads/Tor] $ ./tor
Jan 01 17:45:14.797 [notice] Tor 0.3.2.7-rc running on Darwin with Libevent 2.0.22-stable, OpenSSL 1.0.2n, Zlib 1.2.11, Liblzma N/A, and Libzstd N/A.
Jan 01 17:45:14.798 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jan 01 17:45:14.798 [notice] Read configuration file "/var/tmp/dist/tor/etc/tor/torrc".
Jan 01 17:45:14.801 [warn] ControlPort is open, but no authentication method has been configured. This means that any program on your computer can reconfigure your Tor. That's bad! You should upgrade your Tor controller as soon as possible.
Jan 01 17:45:14.801 [warn] Couldn't set maximum number of file descriptors: Invalid argument
Jan 01 17:45:14.801 [warn] Failed to parse/validate config: Problem with ConnLimit value. See logs for details.
Jan 01 17:45:14.801 [err] Reading config failed--see warnings above.

comment:15 Changed 2 years ago by thomasd3

Firefox 57 worked properly for me. I got this laptop in August 2017, so I can't say for Firefox releases prior to that date.

comment:16 in reply to:  15 Changed 2 years ago by Dbryrtfbcbhgf

Replying to thomasd3:

Firefox 57 worked properly for me. I got this laptop in August 2017, so I can't say for Firefox releases prior to that date.

A user on Stackexchange said that running the below command fixed the issue, please test it and post results.

sudo launchctl limit maxfiles 10000 10000 Temporary fix until tor fixes the underlined bug, Thanks fink

https://tor.stackexchange.com/questions/16033/tor-unexpectedly-exited-this-might-be-due-to-a-bug-in-tor-itself-another-progr

Last edited 2 years ago by Dbryrtfbcbhgf (previous) (diff)

comment:17 Changed 2 years ago by Dbryrtfbcbhgf

Component: Applications/Tor BrowserCore Tor/Tor

comment:18 Changed 2 years ago by Dbryrtfbcbhgf

Version: Tor: 0.3.2.7-rc

comment:19 Changed 2 years ago by Dbryrtfbcbhgf

Resolution: duplicate
Status: needs_informationclosed

Duplicate of #21074

comment:20 Changed 2 years ago by thomasd3

Yes, that fixed the problem!

btw, in the very last update of the OS, these appeared:

[loaded] limit.maxfiles.plist (Apple, Inc. - installed 2017-12-27)
[loaded] limit.maxproc.plist (Apple, Inc. - installed 2017-12-27)

I am not sure if this is related, but the problem appeared at about the same time.

comment:21 Changed 2 years ago by thomasd3

Looking at this, I found the something: I have a tool called jBridgeM (it's used to wrap x86 audio plugins in a x64 container) and can be found here: https://jstuff.wordpress.com/jbridgem/

It is the one that installed the plist files with maxfiles / maxproc, not the OS update

The content of the file is:

[thomas:/Library/LaunchDaemons] $ cat limit.maxfiles.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-AppleDTD PLIST 1.0EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>limit.maxfiles</string>
<key>ProgramArguments</key>
<array>
<string>launchctl</string>
<string>limit</string>
<string>maxfiles</string>
<string>8192</string>
<string>9223372036854775807</string>
</array>
<key>RunAtLoad</key>
<true/>
<key>ServiceIPC</key>
<false/>
<key>CreatedByjBridgeM</key>
<true/>

</dict>

</plist>

comment:22 in reply to:  20 Changed 2 years ago by Dbryrtfbcbhgf

Replying to thomasd3:

Yes, that fixed the problem!

btw, in the very last update of the OS, these appeared:

[loaded] limit.maxfiles.plist (Apple, Inc. - installed 2017-12-27)
[loaded] limit.maxproc.plist (Apple, Inc. - installed 2017-12-27)

I am not sure if this is related, but the problem appeared at about the same time.

Torproject's developers should be able to fix this issue permanently, Keep up-to-date on their progress by subscribing to this ticket #21074

comment:23 in reply to:  21 Changed 2 years ago by Dbryrtfbcbhgf

Replying to thomasd3:

Looking at this, I found the something: I have a tool called jBridgeM (it's used to wrap x86 audio plugins in a x64 container) and can be found here: https://jstuff.wordpress.com/jbridgem/

It is the one that installed the plist files with maxfiles / maxproc, not the OS update

The content of the file is:

[thomas:/Library/LaunchDaemons] $ cat limit.maxfiles.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-AppleDTD PLIST 1.0EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>limit.maxfiles</string>
<key>ProgramArguments</key>
<array>
<string>launchctl</string>
<string>limit</string>
<string>maxfiles</string>
<string>8192</string>
<string>9223372036854775807</string>
</array>
<key>RunAtLoad</key>
<true/>
<key>ServiceIPC</key>
<false/>
<key>CreatedByjBridgeM</key>
<true/>

</dict>

</plist>

teor responded https://trac.torproject.org/projects/tor/ticket/21074#comment:32

Last edited 2 years ago by Dbryrtfbcbhgf (previous) (diff)

comment:24 in reply to:  20 Changed 23 months ago by Dbryrtfbcbhgf

Replying to thomasd3:

Yes, that fixed the problem!

btw, in the very last update of the OS, these appeared:

[loaded] limit.maxfiles.plist (Apple, Inc. - installed 2017-12-27)
[loaded] limit.maxproc.plist (Apple, Inc. - installed 2017-12-27)

I am not sure if this is related, but the problem appeared at about the same time.

The underlining bug has been fixed in the latest commit in the source code, the bug fix should included in the next build of Tor 0.3.3.1-alpha . "The fix could be back ported to older versions."
https://gitweb.torproject.org/tor.git/commit/?id=454d85436385a7ee0b60f18834d707d72b08b915

Minor bugfixes: Don't exit the Tor process if setrlimit() fails to change the filelimit (which can happen sometimes on some versions of OSX). Fixes bug 21074; bugfix on 0.0.9pre5.
Last edited 22 months ago by Dbryrtfbcbhgf (previous) (diff)
Note: See TracTickets for help on using tickets.