Opened 7 months ago

Closed 6 months ago

#24772 closed defect (worksforme)

Weird "Connection is Not Secure" message when using Tor Browser.

Reported by: cypherpunks Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Recently, when I visit https websites, sometimes I get this message.

http://6zc6sejeho3fwrd4.onion/#K52-tw8DvqUge-MoxW4DSg

Technica Details said:
Broken Encryption (TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384, 256bit, TLS1.2)

My Tor Browser's TorButton settings is "High".
This didn't happen until recently.
And no, my PC is not infected.

Does anyone have a same problem?

Child Tickets

Change History (8)

comment:1 Changed 7 months ago by cypherpunks

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team
Priority: MediumHigh
Severity: NormalMajor

comment:2 Changed 7 months ago by Dbryrtfbcbhgf

Resolution: invalid
Status: newclosed

All .onion sites are encrypted end to end, the browser does not Reflect that when you click the "!" next to the URL.
As long as it is a .onion site it is encrypted end to end, some onion sites will also use https But that's just another layer of encryption. Also some great information https://trac.torproject.org/projects/tor/ticket/21952

Next Gen Onion Services, Better crypto (replaced SHA1/DH/RSA1024 with SHA3/ed25519/curve25519)

Last edited 7 months ago by Dbryrtfbcbhgf (previous) (diff)

comment:3 Changed 7 months ago by Dbryrtfbcbhgf

Resolution: invalid
Status: closedreopened

comment:4 Changed 7 months ago by Dbryrtfbcbhgf

Resolution: duplicate
Status: reopenedclosed

Duplicate of #8686

comment:5 Changed 7 months ago by cypherpunks

Resolution: duplicate
Status: closedreopened

You didn't take a look at my screenshot, did you?
It's happening on clearnet sites.

comment:6 in reply to:  5 Changed 7 months ago by Dbryrtfbcbhgf

Replying to cypherpunks:

You didn't take a look at my screenshot, did you?
It's happening on clearnet sites.

This is a problem on the websites server side, contact the website's admins so they can fix the issue. It's hard to troubleshoot this possible issue, because you did not provide any links to the websites affected.
Both onion sites and clearnet sites can have HTTPS.

Example https://protonirockerxow.onion

Last edited 7 months ago by Dbryrtfbcbhgf (previous) (diff)

comment:7 Changed 7 months ago by Dbryrtfbcbhgf

Status: reopenedneeds_information

comment:8 Changed 6 months ago by gk

Resolution: worksforme
Status: needs_informationclosed

Seems to work for me.

Note: See TracTickets for help on using tickets.