#24775 closed defect (duplicate)

Reduce "Channel padding timeout scheduled" NOTICE messages

Reported by: Dbryrtfbcbhgf Owned by:
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 032-backport, 031-backport, 033-must, annoyance, 033-triage-20180320, 033-included-20180320
Cc: mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

My relay's logs keep getting filled up with [NOTICE] Channel padding timeout scheduled. The frequency of these logs need to be reduced.

16:42:25 [NOTICE] Channel padding timeout scheduled 504765ms in the past.│ 16:32:48 [NOTICE] Channel padding timeout scheduled 248427ms in the past.│ 16:32:48 [NOTICE] Channel padding timeout scheduled 195991ms in the past.│ 16:32:48 [NOTICE] Channel padding timeout scheduled 177137ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 173188ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 149139ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 232423ms in the past.│ 14:29:47 [NOTICE] R):│ 16:42:25 [NOTICE] Channel padding timeout scheduled 504765ms in the past.│ 16:32:48 [NOTICE] Channel padding timeout scheduled 248427ms in the past.│ 16:32:48 [NOTICE] Channel padding timeout scheduled 195991ms in the past.│ 16:32:48 [NOTICE] Channel padding timeout scheduled 177137ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 173188ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 149139ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 232423ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 245152ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 214414ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 155918ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 151024ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 265701ms in the past.│ 14:16:02 [NOTICE] Channel padding timeout scheduled 241977ms in the past.│ 12:41:47 [NOTICE] Channel padding timeout scheduled 180521ms in the past.│ 12:41:47 [NOTICE] Channel padding timeout scheduled 286639ms in the past.│ 12:41:47 [NOTICE] Channel padding timeout scheduled 259299ms in the past.│ 12:41:47 [NOTICE] Channel padding timeout scheduled 184434ms in the p 245152ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 214414ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 155918ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 151024ms in the past.│ 14:29:47 [NOTICE] Channel padding timeout scheduled 265701ms in the past.│ 14:16:02 [NOTICE] Channel padding timeout scheduled 241977ms in the past.│ 12:41:47 [NOTICE] Channel padding timeout scheduled 180521ms in the past.│ 12:41:47 [NOTICE] Channel padding timeout scheduled 286639ms in the past.│ 12:41:47 [NOTICE] Channel padding timeout scheduled 259299ms in the past.│ 12:41:47 [NOTICE] Channel padding timeout scheduled 184434ms in the past

Tor 0.3.1.9

Child Tickets

Change History (10)

comment:1 Changed 21 months ago by Dbryrtfbcbhgf

Summary: reduce "Channel padding timeout scheduled" NOTICE messagesReduce "Channel padding timeout scheduled" NOTICE messages

comment:2 Changed 21 months ago by nickm

Cc: mikeperry added
Keywords: 032-backport 031-backport added
Milestone: Tor: 0.3.3.x-final

comment:3 Changed 19 months ago by dgoulet

Keywords: 033-must added

Some ticket dgoulet thinks must go in 033.

comment:4 Changed 19 months ago by cypherpunks

I've just got this message in my tor client log files, 0.3.2.9 (I don't run tor node):

[notice] Channel padding timeout scheduled XXXXXXms in the past

Nothing suspicious was written in logs before or after that. I don't thing my time clock has experienced big jump.

comment:5 Changed 19 months ago by nickm

Could this be a duplicate of #22212? If so, it's fixed in 0.3.3, and scheduled for backport to earlier versions once there's a little more testing.

comment:6 Changed 18 months ago by nickm

Status: newneeds_information

comment:7 Changed 18 months ago by nickm

Keywords: annoyance added

comment:8 Changed 18 months ago by nickm

Keywords: 033-triage-20180320 added

Marking all tickets reached by current round of 033 triage.

comment:9 Changed 18 months ago by nickm

Keywords: 033-included-20180320 added

Mark 033-must tickets as triaged-in for 0.3.3

comment:10 Changed 18 months ago by dgoulet

Resolution: duplicate
Status: needs_informationclosed

Yes this is a duplicate of #22212. I confirm that master doesn't have this issue anymore.

Note: See TracTickets for help on using tickets.