Opened 3 weeks ago

Closed 13 days ago

#24783 closed task (not a bug)

Support browser.storage.sync.*

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I know Tor browser didn't support Firefox Sync.
It's okay but would you consider supporting browser.storage.sync.*?

browser.storage.local.* are working fine.
browser.storage.sync.* will return nothing.

This is not my code's problem because sync. is working in Mozilla Firefox.
How about treating storage.sync request as storage.local internally?
(I'm not asking for enabling sync - I just want .sync to work as .local)

Child Tickets

Attachments (1)

samplefortor.zip (3.8 KB) - added by cypherpunks 2 weeks ago.
Sample add-on code and readme

Download all attachments as: .zip

Change History (5)

comment:1 Changed 3 weeks ago by tom

Could you explain what you are trying to do? I can't infer it from your description, and I think it would be helpful to understand the full use case you're trying to accomplish so we can understand what we broke. Thanks!

Changed 2 weeks ago by cypherpunks

Attachment: samplefortor.zip added

Sample add-on code and readme

comment:2 Changed 2 weeks ago by cypherpunks

@tom I've attached a sample code and readme.

comment:3 Changed 2 weeks ago by cypherpunks

Status: newneeds_review

comment:4 Changed 13 days ago by mcs

Resolution: not a bug
Status: needs_reviewclosed

According to the following document, browser.storage.sync is not available in Firefox 52 ESR (which is the version of Firefox that Tor Browser is based on):
https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/storage/sync

For now this is not a bug, and this functionality may "just work" when Tor Browser switches to Firefox 59 ESR.

Note: See TracTickets for help on using tickets.