Opened 2 years ago

Closed 2 years ago

#24784 closed defect (duplicate)

New Identity doesn't revoke temporary javascript permissions on TBB

Reported by: mercedes508 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In Tor Browser, if you temporarily allow a Website to use JavaScript and use the New Identity button and go back to the exact same website afterwards no script will forget that it granted temporary access to it pre-new identity yet allow scripts to be executed nonetheless

This issue has been reproduced on both Tails 3.3 and Tor Browser 7.0.11 running on Debian stable.

It's been reported on Tails bug tracker first: https://labs.riseup.net/code/issues/15140

Child Tickets

Attachments (1)

example.mp4 (1.7 MB) - added by mercedes508 2 years ago.
video file of the issue

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by mercedes508

Attachment: example.mp4 added

video file of the issue

comment:1 Changed 2 years ago by mercedes508

Summary: New Identity doesn't revoke temporary javascript permissionsNew Identity doesn't revoke temporary javascript permissions on TBB

comment:2 Changed 2 years ago by mcs

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

comment:3 Changed 2 years ago by cypherpunks

Resolution: duplicate
Status: newclosed

Duplicate of #24421

Note: See TracTickets for help on using tickets.