Opened 3 months ago

Last modified 3 months ago

#24850 new defect

tor2web option without the corresponding tag in torrc causes tor to fail with confusing console output

Reported by: yurivict271 Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.3.2.9
Severity: Normal Keywords: tor-logging, tor-config
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The log file explains it:

Jan 09 17:12:29.000 [warn] This copy of Tor was compiled or configured to run in a non-anonymous mode. It will provide NO ANONYMITY.
Jan 09 17:12:29.000 [err] This copy of Tor was compiled to run in 'tor2web mode'. It can only be run with the Tor2webMode torrc option enabled.
Jan 09 17:12:29.000 [err] set_options: Bug: Acting on config options left us in a broken state. Dying. (on Tor 0.3.2.9 9e8b762fcecfece6)

But the console output looks like it fails for no reason:

Starting tor.
Jan 09 17:12:29.178 [notice] Tor 0.3.2.9 (git-9e8b762fcecfece6) running on FreeBSD with Libevent 2.1.8-stable, OpenSSL 1.0.2n, Zlib 1.2.11, Liblzma 5.2.3, and Libzstd 1.3.3.
Jan 09 17:12:29.178 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jan 09 17:12:29.178 [notice] Read configuration file "/usr/local/etc/tor/torrc".
Jan 09 17:12:29.187 [notice] Scheduler type KISTLite has been enabled.
Jan 09 17:12:29.187 [notice] Opening Socks listener on 127.0.0.1:9050
/usr/local/etc/rc.d/tor: WARNING: failed to start tor

Child Tickets

Change History (6)

comment:1 Changed 3 months ago by yurivict271

Summary: tor2web option without the corresponding tag in torrc makes torfail with confusing console outputtor2web option without the corresponding tag in torrc causes tor to fail with confusing console output

comment:2 Changed 3 months ago by gk

Component: - Select a componentCore Tor/Tor

comment:3 Changed 3 months ago by dgoulet

Resolution: not a bug
Status: newclosed

Set Tor2webMode 1 in your torrc file. If not, tor won't start if compiled with tor2web. Once you do so, if you still have the issue, reopen this bug and if you can attach some info logs Log info ... option.

comment:4 Changed 3 months ago by yurivict271

It is clear how to make it start.

The problem is about the lack of the console error message explaining why it didn't start.

comment:5 Changed 3 months ago by yurivict271

Resolution: not a bug
Status: closedreopened

comment:6 Changed 3 months ago by dgoulet

Keywords: tor-logging tor-config added
Milestone: Tor: unspecified
Status: reopenednew

Oh the console... Hmmm, I think this is a whole new ballgame to print a meaningful message on the console also. I guess any critical options that fail could also print on the console before quitting.

Note: See TracTickets for help on using tickets.