Opened 3 months ago

Closed 3 months ago

#24860 closed defect (fixed)

Bug: Assertion cmux failed in circuitmux_get_policy at src/or/circuitmux.c

Reported by: dgoulet Owned by: dgoulet
Priority: High Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-relay, tor-sched, cmux, tor-channel
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This was triggered during an heavy load on my relay for which all the RAM and disk space has been consumed:

Dec 15 20:44:20.612 [err] tor_assertion_failed_(): Bug: src/or/circuitmux.c:630: circuitmux_get_policy: Assertion cmux failed; aborting. (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug: Assertion cmux failed in circuitmux_get_policy at src/or/circuitmux.c:630. Stack trace: (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(log_backtrace+0x42) [0x55cac920c342] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(tor_assertion_failed_+0x8d) [0x55cac922768d] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(circuitmux_get_policy+0x57) [0x55cac9167d57] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(+0xb7f41) [0x55cac913ff41] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(smartlist_pqueue_pop+0x156) [0x55cac9217196] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(+0xb9d7e) [0x55cac9141d7e] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(+0xb805f) [0x55cac914005f] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x819) [0x7f38ac2544c9] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(do_main_loop+0x24f) [0x55cac90db53f] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(tor_run_main+0x265) [0x55cac90dc9c5] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(tor_main+0x3a) [0x55cac90d621a] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(main+0x19) [0x55cac90d5f89] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7f38aaf6d830] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)
Dec 15 20:44:20.678 [err] Bug:     /home/relay/tor/src/or/tor(_start+0x29) [0x55cac90d5fd9] (on Tor 0.3.3.0-alpha-dev b1682551a6860a2b)

Child Tickets

Change History (4)

comment:1 Changed 3 months ago by nickm

Could this be caused by #24700 ?

comment:2 Changed 3 months ago by dgoulet

Owner: set to dgoulet
Status: newaccepted

comment:3 in reply to:  1 Changed 3 months ago by dgoulet

Priority: MediumHigh

Replying to nickm:

Could this be caused by #24700 ?

Hmmmmmm! Actually, it is possible and it might be it... Need to think for a fix but I believe that it is very probable.

comment:4 Changed 3 months ago by dgoulet

Resolution: fixed
Status: acceptedclosed

Should be fixed by #24700.

Note: See TracTickets for help on using tickets.