Opened 9 months ago

Closed 9 months ago

#24874 closed defect (duplicate)

Running out of disk space triggers BUG(ent == NULL) at consdiffmgr.c:1316

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Jan 11 03:30:10.350 [warn] Error writing to "freeBogatov/diff-cache/1090": No space left on device
Jan 11 03:30:10.350 [warn] tor_bug_occurred_(): Bug: src/or/consdiffmgr.c:1316: store_multiple: Non-fatal assertion !(ent == NULL) failed. (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug: Non-fatal assertion !(ent == NULL) failed in store_multiple at src/or/consdiffmgr.c:1316. Stack trace: (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug:     ../tor/src/or/tor(log_backtrace+0x42) [0x7f8075292e82] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug:     ../tor/src/or/tor(tor_bug_occurred_+0xca) [0x7f80752ae21a] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug:     ../tor/src/or/tor(+0x11b718) [0x7f8075223718] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug:     ../tor/src/or/tor(+0x11b9cd) [0x7f80752239cd] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug:     ../tor/src/or/tor(replyqueue_process+0x52) [0x7f80752b1272] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug:     ../tor/src/or/tor(+0x2014f4) [0x7f80753094f4] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug:     ../tor/src/or/tor(+0x201805) [0x7f8075309805] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.397 [warn] Bug:     ../tor/src/or/tor(+0x201e95) [0x7f8075309e95] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.408 [warn] Bug:     ../tor/src/or/tor(event_base_loop+0x2c8) [0x7f807530a5f9] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.408 [warn] Bug:     ../tor/src/or/tor(do_main_loop+0x41b) [0x7f807515aa8b] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.408 [warn] Bug:     ../tor/src/or/tor(tor_run_main+0x28b) [0x7f807515b06b] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.408 [warn] Bug:     ../tor/src/or/tor(tor_main+0x43) [0x7f8075155953] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.408 [warn] Bug:     ../tor/src/or/tor(main+0x19) [0x7f80751557e9] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.408 [warn] Bug:     /lib64/libc.so.6(__libc_start_main+0xfd) [0x7f8073c78d1d] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)
Jan 11 03:30:10.408 [warn] Bug:     ../tor/src/or/tor(+0x4d6f9) [0x7f80751556f9] (on Tor 0.3.3.0-alpha-dev 943134e886d9cef2)

I hit the bug on master, but it looks like it is present in 0.3.2 and 0.3.1 as well.

Child Tickets

Change History (1)

comment:1 Changed 9 months ago by ahf

Resolution: duplicate
Status: newclosed

This is a duplicate of #24859

Note: See TracTickets for help on using tickets.