Opened 5 months ago

Last modified 5 weeks ago

#24943 reopened task

Tor Browser is preventing add-on from saving its setting

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: mikeperry Sponsor:

Description

TL:DR;
I've downloaded an add-on from mozilla, and when I try to configure it the TorButton cleared its settings.

Detail:
First, I thought this might be an add-on's bug. I tested the add-on with Mozilla Firefox ESR and Firefox 57. Both worked without problem.
So I removed the add-on from Tor browser and tried this[1].
When I clicked "Save", it cleared all forms.
The Browser console said TorButton is causing this issue.

I understand you don't want users to add any add-ons to your browser.
But isn't this too much?

[1] https://trac.torproject.org/projects/tor/attachment/ticket/24783/samplefortor.zip

Child Tickets

Change History (11)

comment:1 Changed 5 months ago by cypherpunks

Component: Applications/TorbuttonApplications/Tor Browser
Owner: set to tbb-team

I also can reproduce this. Torbutton generated a WARN log when I clicked save button.

comment:2 Changed 5 months ago by cypherpunks

Parent ID: #24949

comment:3 Changed 5 months ago by cypherpunks

Reviewer: mikeperry

comment:4 Changed 5 months ago by gk

Resolution: duplicate
Status: newclosed

See #24783 for the reason for this behavior.

comment:5 Changed 5 months ago by cypherpunks

Parent ID: #24949
Resolution: duplicate
Status: closedreopened

Reopening this ticket because of this line:

I tested the add-on with Mozilla Firefox ESR

This is clearly suggesting he/she is talking about storage.local.
#24783 is storage."sync".

comment:6 Changed 5 months ago by cypherpunks

Parent ID: #25000

comment:7 Changed 5 months ago by cypherpunks

Points: 100

comment:8 in reply to:  5 Changed 5 months ago by gk

Parent ID: #25000
Priority: HighMedium
Resolution: duplicate
Severity: CriticalNormal
Status: reopenedclosed

Replying to cypherpunks:

Reopening this ticket because of this line:

I tested the add-on with Mozilla Firefox ESR

This is clearly suggesting he/she is talking about storage.local.
#24783 is storage."sync".

Good catch. Then let's have just #25000 for that.

comment:9 Changed 5 months ago by cypherpunks

Points: 100

comment:10 Changed 4 months ago by gk

Resolution: duplicate
Status: closedreopened
Summary: TorButton is preventing from add-on saving its settingTor Browser is preventing add-on from saving its setting

This does not seem to be a duplicate of #25000. Here is what mcs and brade found out:

Unfortunately, it does not fix #24943. In fact, that issue occurs in Tor Browser 8.x even if NoScript is completely disabled and even when all of our bundled add-ons are disabled. The problem does not occur in Firefox ESR 52.6.0. All of these things seem to point to a browser patch as the cause.
Note: See TracTickets for help on using tickets.