#24947 closed defect (duplicate)

vanguards bug: connection_ap_expire_beginning(): Bug: circuit->purpose == CIRCUIT_PURPOSE_C_GENERAL failed.

Reported by: asn Owned by:
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-guard
Cc: mikeperry, ffmancera@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor: SponsorU

Description

On my hsv3 with vanguards enabled I'm getting the following bug on my logs. It was probs caused by #13837 and #23101 which added special circuit purposes for fetching/uploading HS descs.

Jan 20 11:52:52.000 [warn] connection_ap_expire_beginning(): Bug: circuit->purpose == CIRCUIT_PURPOSE_C_GENERAL failed. The purpose on the circuit was Hidden service: Uploading HS descriptor; it was in state open, path_state use attempted. (on Tor 0.3.3.0-alpha-dev d69c8f7117a5975a)

Child Tickets

Change History (4)

comment:1 Changed 17 months ago by ffmancera

Cc: ffmancera@… added

comment:2 Changed 17 months ago by ffmancera

Status: newneeds_review

I worked on that, please check my github branch bug24947. Also I didn't write a change file because the bug isn't in any release, if it is necessary let me know and I will do it.

comment:3 Changed 17 months ago by arma

Be sure to compare to #24946, which looks like a duplicate and also has a proposed patch.

comment:4 in reply to:  3 Changed 17 months ago by ffmancera

Resolution: duplicate
Status: needs_reviewclosed

Be sure to compare to #24946, which looks like a duplicate and also has a proposed patch.

I am closing this ticket, it's completly duplicated and the proposed patch includes mine too.

Note: See TracTickets for help on using tickets.