Opened 4 weeks ago

Closed 4 weeks ago

Last modified 4 weeks ago

#24951 closed defect (duplicate)

Host all Tor websites on V3 onions

Reported by: Dbryrtfbcbhgf Owned by: tpa
Priority: High Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

All the Tor onion sites on https://onion.torproject.org/ should be hosted on V3 onions and Not V2.

Child Tickets

Change History (5)

comment:1 Changed 4 weeks ago by irl

Component: Webpages/WebsiteInternal Services/Tor Sysadmin Team
Owner: set to tpa

Thinking in particular about Debian stable, but I'm sure there are other examples, some may be on older major releases (that still receive updates, but not new features) that then would not be able to access the services.

It would perhaps be more useful to have both v2 and v3 onion services available for a time to allow choice. These service also use OnionBalance, as far as I remember, which currently does not support v3 onion services.

As this is not related to website content but instead to the infrastructure behind it, reassigning to the sysadmin team.

comment:2 Changed 4 weeks ago by cypherpunks

Resolution: duplicate
Status: newclosed

Duplicate: #23614

comment:3 Changed 4 weeks ago by Dbryrtfbcbhgf

Resolution: duplicate
Status: closedreopened

This is not a A duplicate of #23614 This ticket is about all Tor's websites

comment:4 in reply to:  3 Changed 4 weeks ago by cypherpunks

Resolution: duplicate
Status: reopenedclosed

Replying to Dbryrtfbcbhgf:

This is not a A duplicate of #23614 This ticket is about all Tor's websites

Well that's the same thing with that ticket honey, "Switch tp.org Onion Services to "v3"", note that "Onion Services" is in the plural.

comment:5 Changed 4 weeks ago by cypherpunks

@cypherpunks No.4
I understand your frustration. I'll update 23614 for you.

@Dbryrtfbcbhgf
I hope you not to reopen this ticket because above cpunk is the first one who created this ticket.
Also I ask you not to close ticket if you don't write any explanation. Would you think about it for a while?

Note: See TracTickets for help on using tickets.