Opened 9 months ago

Closed 9 months ago

#24974 closed enhancement (fixed)

add onionoo version field to atlas/relay search

Reported by: cypherpunks Owned by: irl
Priority: Low Milestone:
Component: Metrics/Relay Search Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is related to:
https://trac.torproject.org/projects/tor/ticket/22488#comment:23

Goal: reduce the confusion for relay ops caused by false-positives of "you are running an outdated tor version" banner.

Below the platform field add the onionoo version field:
https://metrics.torproject.org/onionoo.html#details_relay_version

Description: Version
Tooltip text: Version of this relay as seen in the tor consensus

Based on the recent discussion on metrics-team ML I'm adding some ticket "metadata":

  • This is a nice-to-have feature
  • Would be nice to have it before 2019

Child Tickets

Change History (7)

comment:1 Changed 9 months ago by irl

Resolution: fixed
Status: newclosed

Fixed in 94c6afc

comment:2 Changed 9 months ago by cypherpunks

Resolution: fixed
Status: closedreopened

Thanks Iain for implementing that. Since this is only relevant for ~10 out of 8k relays,
would you mind displaying it only if

version != 2th word in platform string?

to reduce the redundant information otherwise?

comment:3 Changed 9 months ago by cypherpunks

And maybe lets rename it from just "Version" to "Tor Version"

comment:4 Changed 9 months ago by irl

We've not hidden any other fields when they contain redundant information, only when the information doesn't exist, and in most cases we explicitly say that the information doesn't exist.

Maybe though this shouldn't be another field and should instead just be "(X.X.X in consensus)" following the platform line if they are different. What do you think?

comment:5 Changed 9 months ago by cypherpunks

that is an even better idea!

comment:6 Changed 9 months ago by irl

Owner: changed from metrics-team to irl
Status: reopenedaccepted

Ok, I'll update it to do that instead.

comment:7 Changed 9 months ago by irl

Resolution: fixed
Status: acceptedclosed

Fixed in b186e90.

Note: See TracTickets for help on using tickets.