Opened 7 years ago

Closed 7 years ago

#2501 closed defect (fixed)

Useless warning on arm startup

Reported by: torland Owned by: atagar
Priority: Low Milestone:
Component: Core Tor/Nyx Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am using arm on several relays. On all relays arm gives out this warning on startup

12:39:28 [ARM_WARN] The torrc differ from what tor's using. You can issue a sighup to reload the torrc values by pressing x.

  • configuration value is missing from the torrc:

tor is using the same torrc that arm is complaining.

Child Tickets

Change History (11)

comment:1 Changed 7 years ago by atagar

Status: newassigned

Hi torland. I've had others report this too but I've never been able to reproduce it. Could you please provide the arm version (the "arm --version" output) and your torrc scrubbed of any private information so I can attempt to reproduce this?

Thanks! -Damian

comment:2 Changed 7 years ago by atagar

Resolution: user disappeared
Status: assignedclosed

Hm, it's been a week but no reply. I'm gonna close this ticket since I can't repro. Please reopen if you have a use case for me to try. Cheers! -Damian

comment:3 Changed 7 years ago by talion

Resolution: user disappeared
Status: closedreopened

Same problem here on 5.0.8 64bit, tor and arm installed from repositories.
Apart from the warning, writing a new configuration from arm with 'w' results in an empty torrc file.

$ arm --version
arm version 1.4.0.2 (released November 30, 2010)

/etc/tor/torrc:
SocksPort 9050
SocksListenAddress 127.0.0.1
SocksListenAddress 81.88.24.216:9100
SocksPolicy accept 81.88.24.216
Log notice file /var/log/tor/notices.log
RunAsDaemon 1
DataDirectory /var/lib/tor
ControlPort 9051
HashedControlPassword 16:xxxxxxx
ORPort 9001
Nickname xxxxxxx
Address xxxxxx
RelayBandwidthRate 5000 KBytes
RelayBandwidthBurst 10000 KBytes
ContactInfo xxxxxx
DirPort 9030 # what port to advertise for directory connections
DirPortFrontPage /etc/tor/exit-notice.html
BridgeRelay 1
ExitPolicy reject *:*

$ tor -version
Feb 14 20:30:07.628 [notice] Tor v0.2.1.29 (r98a499a5377f18b1). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux x86_64)

comment:4 Changed 7 years ago by atagar

Fantastic! There's been a new arm release (the current version is 1.4.1.3:
http://www.atagar.com/arm/download.php

Does the problem persist with that version? Also, you mentioned that using 'w' to write a new torrc results in a blank file. Does the preview window display that it's going to save anything?

I'll give this a shot later after work. Thanks again! -Damian

comment:5 Changed 7 years ago by talion

arm --version
arm version 1.4.1.3 (released January 15, 2011)

Does the problem persist with that version?

Yes:
22:28:04 [ARM_WARN] The torrc differ from what tor's using. You can issue a sighup to reload the torrc values by pressing x.

blank file

All entries are highlighted in blue, so I guess, arm thinks its correct to save an empty file?
22:28:04 [ARM_NOTICE] Unneeded torrc entries found. They've been highlighted in blue on the torrc page.

comment:6 Changed 7 years ago by atagar

Status: reopenedassigned

All entries are highlighted in blue, so I guess, arm thinks its correct to save an empty file?

Arm uses 'GETINFO config-text' (the same method as Vidalia) for fetching the current config values from Tor so if that's empty then Tor thinks that everything matches the defaults. Some of your options (like the SocksListenAddress) match the defaults so arm should give you a notice about them, and drop them from the saved file. However, most are custom.

Are you positive that Tor is loading this torrc? These results would make perfect sense if Tor hadn't loaded any configuration (and hence were using the defaults for everything).

I'll give this a shot after work. Cheers! -Damian

comment:7 Changed 7 years ago by atagar

Hi, I've tried with the torrc you provided minus the bits that would make starting tor a pita:
SocksPort 9050
SocksListenAddress 127.0.0.1
Log notice file /tmp/notices.log
ControlPort 9051
ORPort 9001
Nickname xxxxxxx
RelayBandwidthRate 5000 KBytes
RelayBandwidthBurst 10000 KBytes
ContactInfo xxxxxx
DirPort 9030
BridgeRelay 1
ExitPolicy reject *:*

But the problems that you mentioned didn't manifest. Arm gave a notice that the SocksPort matched the default, but that's intended. Trying to save a torrc ('w' on the config page) produces the expected results.

I'm highly suspecting that your Tor instance isn't running the configuration you think it is. -Damian

comment:8 Changed 7 years ago by talion

I'm highly suspecting that your Tor instance isn't running the configuration you think it is.

It must be using it, because for example with a different SocksPolicy it rejects the client.
I have a look on that again later, I have no time for that now.

comment:9 Changed 7 years ago by atagar

Ah ha! Found the problem. The GETINFO config-text option was added in 0.2.2.7-alpha, so arm's unable to fetch your current configuration (hence saving is failing and it thinks you don't have a config set). I wonder what vidalia does for this since this should mean that it's unable to save the config for the stable versions too...

I'll add fallback logic so that it skips torrc validation (or offering to save the config) when that option's unavailable. Thanks! -Damian

comment:10 Changed 7 years ago by atagar

Fix checked in (r24455). There should be a new arm release in the next few days.

comment:11 Changed 7 years ago by atagar

Resolution: fixed
Status: assignedclosed

The fix has been released in 1.4.2 - resolving.

Note: See TracTickets for help on using tickets.