Opened 7 months ago

Closed 7 months ago

#25026 closed defect (implemented)

Update HiddenServiceVersion in tor.1.txt to only allow one of the HS version 2 or 3

Reported by: ahf Owned by:
Priority: Low Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version:
Severity: Minor Keywords: 032-backport
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The current HiddenServiceVersion man page entry for tor is:

[[HiddenServiceVersion]] **HiddenServiceVersion** __version__,__version__,__...__::

Which reads like the config entry takes a list of version where in reality it only accept either 2 or 3.

Child Tickets

Change History (4)

comment:1 Changed 7 months ago by ahf

Status: newneeds_review

comment:2 Changed 7 months ago by nickm

lgtm; I'll merge after the alpha comes out today.

comment:3 Changed 7 months ago by nickm

Status: needs_reviewmerge_ready

comment:4 Changed 7 months ago by nickm

Resolution: implemented
Status: merge_readyclosed

Merged!

Note: See TracTickets for help on using tickets.