#25042 closed defect (wontfix)

Connecting to tor cuts my connection to the internet.

Reported by: GGNderbomb Owned by: ioerror
Priority: Medium Milestone:
Component: Archived/Torouter Version:
Severity: Blocker Keywords: archived-closed-2018-07-04
Cc: ggnderbomb@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi. I own an anonabox openwrt router and have recently updated to the latest version of tor availible for it. My last version of tor was 0.2.9.9 and it has worked fine. ever since I upgraded to 0.3.1.8-1, however, whenever I start tor on the router, all devices connected to the router act like they're offline. I have tried across multiple devices with multiple web browsers, but none of them seem to successfully connect to a website. Whenever I have tor disconnected, everything works perfectly fine. I've re-installed tor 0.3.1.8-1 multiple times, yet it seems to not help at all. I've tried reaching out to anonabox, but haven't gotten a reply in weeks.I'll attach pictures of my config file and proxy configuration just in case they matter. if anyone has a solution to my problem, please let me know.

Child Tickets

Attachments (3)

2018-01-26_18-38-26.png (50.0 KB) - added by GGNderbomb 23 months ago.
config file
2018-01-26_18-41-23.png (47.1 KB) - added by GGNderbomb 23 months ago.
2018-01-26_18-42-53.png (29.1 KB) - added by GGNderbomb 23 months ago.
proxy config

Download all attachments as: .zip

Change History (6)

Changed 23 months ago by GGNderbomb

Attachment: 2018-01-26_18-38-26.png added

config file

Changed 23 months ago by GGNderbomb

Attachment: 2018-01-26_18-41-23.png added

Changed 23 months ago by GGNderbomb

Attachment: 2018-01-26_18-42-53.png added

proxy config

comment:1 Changed 23 months ago by cypherpunks

I am not familiar with anonabox, but I'll give it a go.

Advanced Configuration

VirtualAddrNetwork 10.192.0.0/10
TransPort 9040
TransListenAddress 192.168.19.84
DNSPort 9053
DNSListenAddress 192.168.19.84
ClientTransportPlugin obfs2,obfs3,scramblesuit exec /usr/bin/obfsclient
[...]
## Last updated 12 September 2012 for Tor 0.2.4.3-alpha
## (may or may not work for much older or much newer versions of Tor.)
[...]
## Tor opens a socks proxy on port 9050 by default -- even if you
## configure one below. Set "SocksPort 0" if you plan to run Tor only
## as a relay, and not make any local application connections yourself.
SocksPort 0

I bolded some parts. Are the IPs beginning with 192. or the 10. with CIDR subnet and their ports the same as those that your devices are configured to connect through? Is SocksPort supposed to be 0 on anonabox, implying every device runs tor and thinks anonabox is a bridge? I don't see a BridgeRelay line while SocksPort is 0. Does it not exist, or did you forget to attach a picture of it? Version 0.2.4.3 is extremely old, so you should start with a default torrc for version 0.3.1.8 as a template and overwrite any line with the same variable as in yours with the value that yours is set to. New variables may have been introduced, deprecated, or removed altogether. Take the time to read the comments in the config file (lines starting with ##). Variables in the configuration file may be turned off or set to default by commenting-out their line (starting a line with a single # to make tor think it is a comment and ignore it).

I cannot find the variables above the first comment line...

## Configuration file for a typical Tor user

...in any versions of tor's torrc config file as far back as 0.2.4.3-alpha, so those variables are probably used by anonabox and not by the tor binary executable. Copy those to your new configuration. While you're at it, look at the ClientTransportPlugin line. The Tor Project has deprecated obfsclient in favor of separate "pluggable transports" for bridge protocols. Check that obfsclient is updated or that obfs4proxy is installed and updated, and then consider changing...

ClientTransportPlugin obfs2,obfs3,scramblesuit exec /usr/bin/obfsclient

to

ClientTransportPlugin obfs4,obfs3 exec /usr/bin/obfs4proxy

But be careful because other things in anonabox may not be designed for new versions of obfs4proxy.

If you get it to work, send your procedure and a link to this ticket in a bug report to the anonabox developers.

comment:2 Changed 19 months ago by teor

Milestone: Tor: 0.3.1.x-final
Version: Tor: 0.3.1.8

comment:3 Changed 18 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: newclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.