Opened 3 years ago

Closed 3 years ago

#25052 closed defect (duplicate)

[armhf, tor] strange "your system clock just jumped" warnings

Reported by: bundesgebaermutter Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version: Tor: 0.3.2.9
Severity: Normal Keywords: clock, jumped
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I recently upgraded to 0.3.2 because 0.3.0 won´t be supported beyond the end of this month anymore. The warning first occured in 0.3.1 by the way. The tor relay is running on a bananapi box on Debian Jessie and a custom grsec enabled kernel 4.8 (soon to be upgraded to stretch).

https://atlas.torproject.org/#details/15841A96CA5C1171985A9565BF7CDDFE2BF8E91E

At first I thought the new "diff-cache" consumes too much cpu and causes the clock jump warning. But even if I set the consensus age to one second, the warning won´t disappear. They can be found one or two times per hour in the syslog saying the clock is 100-500 (forward) seconds off.

A ntp client is running to keep the clock up to date. So I began to record the clock skew into a rrd and queried(*) the local network ntp server every ten seconds. The average is 1.6 milliseconds so far.

Maybe the experts have some ideas. Thanks for your time :)


Collected information can be found on the webserver - please don´t mind the self-signed certificate:

The clock skew graph:
https://bundesgebaermutter.ddnss.eu/graphs/torinfo4.png

CPU usage (tor is limited to one core at the moment):
https://bundesgebaermutter.ddnss.eu/graphs/torinfo5.png

An excerpt of tor´s debug log around a clock jump:
https://bundesgebaermutter.ddnss.eu/torlog.sample1.gz

(*) = ntpdate-debian -q -p2 ntp-server-ip-address

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by teor

Resolution: duplicate
Status: newclosed

Hi, please try setting "DirCache 0" on your relay.
If this fixes the issue, then your CPU pinning is causing Tor's main thread to hang when it processes directory documents, and this is a duplicate of #23275.

If not, you probably have a slow resolver, and this is a duplicate of #20423.

Note: See TracTickets for help on using tickets.