#25078 closed defect (duplicate)

Change app.update.url to point to onion service

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

As of TBB 7.5, app.update.url points to https://aus1.torproject.org . Wouldn't it be more sensible for the Tor Project to point automatic updates of its software to services it operates inside of the Tor network that it maintains? Metrics could also benefit. The onion service of aus1 is listed on onion.torproject.org.

Child Tickets

Change History (3)

comment:1 Changed 23 months ago by cypherpunks

A next-generation v3 onion service would be preferable to the v2 one on onion.torproject.org.

comment:2 in reply to:  1 ; Changed 23 months ago by teor

Replying to cypherpunks:

As of TBB 7.5, app.update.url points to https://aus1.torproject.org . Wouldn't it be more sensible for the Tor Project to point automatic updates of its software to services it operates inside of the Tor network that it maintains? Metrics could also benefit. The onion service of aus1 is listed on onion.torproject.org.

Downloads would be slower, and put more load on the network, because the torproject onion services are not single onion services. Migration is blocked on #21117.

Replying to cypherpunks:

A next-generation v3 onion service would be preferable to the v2 one on onion.torproject.org.

I think there is a ticket for torproject to run v3 onion services as well, but I can't find it.

comment:3 in reply to:  2 Changed 23 months ago by gk

Resolution: duplicate
Status: newclosed

Replying to teor:

Replying to cypherpunks:

As of TBB 7.5, app.update.url points to https://aus1.torproject.org . Wouldn't it be more sensible for the Tor Project to point automatic updates of its software to services it operates inside of the Tor network that it maintains? Metrics could also benefit. The onion service of aus1 is listed on onion.torproject.org.

Downloads would be slower, and put more load on the network, because the torproject onion services are not single onion services. Migration is blocked on #21117.

FWIW: app.update.url is responsible to fetch the update meta data which is just a plan XML file and pretty tiny compared to the actual update which is fetched from Fastly infrastructure. Thus, the extra load/additional latency would probably be not that high. That said, this is a duplicate of #17216.

Note: See TracTickets for help on using tickets.