#25154 closed defect (fixed)

Tab crashing in sandboxed 8.0a1, sandbox 0.0.16, linux x86_64

Reported by: ln5 Owned by: yawning
Priority: Medium Milestone:
Component: Archived/Tor Browser Sandbox Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This URL makes the tab crash when js is enabled:
https://peeringdb.com/net/4291

Child Tickets

Change History (10)

comment:1 Changed 19 months ago by yawning

Does this happen with 7.5?

comment:2 Changed 19 months ago by pospeselr

It does not

comment:3 Changed 19 months ago by gk

Component: Applications/Tor BrowserApplications/Tor Browser Sandbox
Owner: changed from tbb-team to yawning

It works fine for me in a non-sandboxed environment but I can reproduce ln5's issue with both 7.5 and 8.0a1 when run with sandbox 0.0.16. Moving this over to yawning then.

comment:4 Changed 19 months ago by yawning

I don't have time to look at this. Patches accepted.

comment:5 Changed 19 months ago by cypherpunks

lol just nuke sandboxed-tor-browser already, or kill it with fire. FF60 ESR has currently sandbox level 4, from about:support in the latest nightly,

Seccomp-BPF (System Call Filtering) true
Seccomp Thread Synchronization true
User Namespaces true
Content Process Sandboxing true
Media Plugin Sandboxing true
Content Process Sandbox Level 4
Effective Content Process Sandbox Level 4

comment:6 in reply to:  5 ; Changed 19 months ago by yawning

Replying to cypherpunks:

lol just nuke sandboxed-tor-browser already, or kill it with fire. FF60 ESR has currently sandbox level 4, from about:support in the latest nightly,

My plan has been to cease work on it utterly after the 7.5 stable time frame, so you'll get your wish sooner than later, go bother someone else. That said, there's things that Mozilla's sandbox will never handle correctly that are applicable to Tor Browser.

comment:7 in reply to:  6 Changed 19 months ago by cypherpunks

Replying to yawning:

My plan has been to cease work on it utterly after the 7.5 stable time frame, so you'll get your wish sooner than later, go bother someone else.

Sorry, didn't mean it in an offensive way since I valued your work on the sandbox and continue to value your other non-sandboxy work.

That said, there's things that Mozilla's sandbox will never handle correctly that are applicable to Tor Browser.

True, but at least we can take comfort in the fact that the situation is orders of magnitude better than it was pre-sandboxed-ESR52.

comment:8 Changed 17 months ago by arma

https://www.washingtonpost.com/news/morning-mix/wp/2018/03/21/austin-bombing-suspect-dies-after-detonating-explosive-in-his-vehicle-police-say/
does it to me too, in my sandboxed-tor-browser running tor browser 7.5.2.

I just filed #25567 which apparently is a duplicate of this one.

For me it started with the upgrade from 7.5 to 7.5.1: 7.5 in sandboxed-tor-browser was solid, and 7.5.1 was not.

comment:9 Changed 17 months ago by arma

For posterity, my complaints in stdout were:

2018/03/21 09:29:10 firefox: [Parent 3] WARNING: pipe error (88): Connection reset by peer: file /var/tmp/build/firefox-fcaf1340c7f0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322
2018/03/21 09:29:10 firefox: [Parent 3] WARNING: pipe error (57): Connection reset by peer: file /var/tmp/build/firefox-fcaf1340c7f0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322
2018/03/21 09:29:10 firefox: [Parent 3] WARNING: pipe error (30): Connection reset by peer: file /var/tmp/build/firefox-fcaf1340c7f0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322
2018/03/21 09:29:10 firefox: ###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0084,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
2018/03/21 09:29:10 firefox: ###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0084,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
2018/03/21 09:29:10 firefox: ###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0084,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
2018/03/21 09:29:10 firefox: ###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0084,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
2018/03/21 09:29:10 firefox: ###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0084,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

comment:10 Changed 17 months ago by yawning

Resolution: fixed
Status: newclosed

Is this just #25540-come-early

That's what a sensible person would do.

or is this a little simple bug that should be found and squashed? :)

https://gitweb.torproject.org/tor-browser/sandboxed-tor-browser.git/commit/?id=bec4340f2083dcc5779859cee26d6809f7def083

Note: See TracTickets for help on using tickets.