#25178 closed defect (fixed)

Running 'make testbuild' does not build the windows-x86_64 version

Reported by: boklm Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, TorBrowserTeam201802R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When running make testbuild we don't build anymore the Window 64 version.

I think this is caused by the change from commit dc51005d4944d6be9ca1c06331c3f9ee1cee51fc:

diff --git a/projects/release/config b/projects/release/config
index e53ea43..f0d95c7 100644
--- a/projects/release/config
+++ b/projects/release/config
@@ -29,7 +29,7 @@ targets:
       torbrowser-windows-i686: 1
   torbrowser-windows-x86_64:
     var:
-      torbrowser-windows-x86_64: 1
+      torbrowser-windows-x86_64: '[% c("var/alpha") || c("var/nightly") %]'
   torbrowser-osx-x86_64:
     var:
       torbrowser-osx-x86_64: 1

The testbuild build is started with:

$(rbm) build release --target testbuild --target torbrowser-all

At this point (in projects/release), var/alpha or var/nightly is not yet set, so var/torbrowser-windows-x86_64 is false.

Child Tickets

Change History (2)

comment:1 Changed 22 months ago by boklm

Keywords: TorBrowserTeam201802R added
Status: newneeds_review

Since the only case where we want to disable the windows-x86_64 build is when we have --target release, we can replace the var/torbrowser-windows-x86_64 condition with ! c("var/release").

I pushed a patch doing that in branch bug_25178:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_25178&id=707cf3d03024780124ab9cda854244ca2ffbccaf

comment:2 Changed 21 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks. Merged to master (commit 3d47438b84102e6831c0905764cb96d479e4580a).

Note: See TracTickets for help on using tickets.