Opened 2 years ago

Closed 2 years ago

#25235 closed defect (not a bug)

Guard node is not pinned

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I see guard node changing every circuit. Is it intended?

Child Tickets

Change History (6)

comment:1 Changed 2 years ago by cypherpunks

Can you see how many guard fingerprints are mentioned in your state file? Also what is your setup (i.e. Tor Browser? or something else??)?

comment:2 Changed 2 years ago by cypherpunks

Status: newneeds_information

comment:3 Changed 2 years ago by nickm

Component: Core TorCore Tor/Tor

comment:4 Changed 2 years ago by cypherpunks

Can you see how many guard fingerprints are mentioned in your state file?

7

Also what is your setup (i.e. Tor Browser? or something else??)?

Tor Browser.

comment:5 Changed 2 years ago by teor

It is normal for tor to change guards if your guards go down.
Tor will try a few guards, but keep retrying the ones that are down.

Have you changed the configuration in any way?

comment:6 Changed 2 years ago by teor

Resolution: not a bug
Status: needs_informationclosed

I don't think this is a bug.
It's likely due to the extra network load recently,

Note: See TracTickets for help on using tickets.