Opened 19 months ago

Closed 4 days ago

#25265 closed defect (fixed)

Set consensus parameter CircuitPriorityHalflife to enable the EWMA circuit policy

Reported by: dgoulet Owned by:
Priority: Medium Milestone:
Component: Core Tor/Chutney Version:
Severity: Normal Keywords:
Cc: teor Actual Points:
Parent ID: #25157 Points:
Reviewer: Sponsor:

Description

So turns out that Chutney is not using EWMA policy at all for circuit priority which means that its been using the default policy which is round robin.

I found this by working on a patch that for testing was assert()ing on the cmux->policy and it exploded.

See cell_ewma_set_scale_factor() on how the EWMA policy is enabled/disabled.

The real network sets: CircuitPriorityHalflifeMsec 30000

Child Tickets

Change History (3)

comment:1 Changed 19 months ago by teor

Parent ID: #25157

Chutney should use the consensus parameters from the public network, see #25157.
For bonus points, we'll work out some way of keeping them in sync.

comment:2 Changed 14 months ago by teor

Cc: teor added; teor@… removed

Shorten useful CCs

comment:3 Changed 4 days ago by dgoulet

Resolution: fixed
Status: newclosed

This is fixed now. The default value that tor takes is what the network uses: CircuitPriorityHalflifeMsec 30000.

Confirmed with a chutney log:

net/nodes.1565707893/004r/info.log:Aug 13 10:53:04.271 [info] cmux_ewma_set_options(): Enabled cell_ewma algorithm because of value in CircuitPriorityHalflifeMsec in consensus; scale factor is 0.793701 per 10 seconds

Note: See TracTickets for help on using tickets.