Opened 12 months ago

Closed 9 months ago

#25279 closed defect (worksforme)

Stem test-full fails on master branch

Reported by: ffmancera Owned by:
Priority: Medium Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: stem, test, 034-triage-20180328
Cc: nickm, atagar Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am getting some errors when executing "make test-full" on a clear version of master branch.

test_parsing_with_example                                    [FAILURE]
test_parsing_with_unknown_options                            [FAILURE]
test_query                                             1 ms  [SUCCESS]
test_query_on_failure                                  0 ms  [SUCCESS]
test_saving_manual_as_config                                 [FAILURE]
test_saving_manual_as_sqlite                                 [FAILURE]
.
.
.
test_connections_by_ss                                       [FAILURE]
.
.
.
[UNIT TEST] test_saving_manual_as_config (test.unit.manual.TestManual) ... ERROR
[UNIT TEST] test_saving_manual_as_sqlite (test.unit.manual.TestManual) ... ERROR
[RUN_PTRACE] test_connections_by_ss (test.integ.util.connection.TestConnection) ... ERROR

I think it is not a regression since maint-0.3.3 because it is failing on one of my bug branch (before release maint-0.3.3).

Nick suggested it could be a sandbox/libc problem.

Child Tickets

Change History (6)

comment:1 Changed 12 months ago by dgoulet

Keywords: test added
Milestone: Tor: 0.3.4.x-final

comment:2 Changed 12 months ago by nickm

Cc: atagar added
Keywords: stem added; chutney removed

Those look like stem tests, not chutney.

comment:3 Changed 12 months ago by nickm

Summary: Chutney test-full fails on master branchStem test-full fails on master branch

comment:4 Changed 12 months ago by atagar

Status: newneeds_information

Hi ffmancera, that's odd. The unit tests aren't failing in that way for me, though I did find some python3 compatibility issues that are now fixed.

Please get a fresh clone of Stem and run its tests directly...

https://stem.torproject.org/faq.html#how-do-i-run-the-tests

If they run into any issues then please include the full test output (the above doesn't have much to go on). Thanks!

comment:5 Changed 11 months ago by nickm

Keywords: 034-triage-20180328 added

comment:6 Changed 9 months ago by nickm

Resolution: worksforme
Status: needs_informationclosed

Closing as "works for me", but please reopen if you can reproduce this with the latest tor and stem ?

Note: See TracTickets for help on using tickets.