#25293 closed defect (not a bug)

tor router in raspberry pi3

Reported by: osos Owned by:
Priority: Medium Milestone: Tor: 0.2.9.x-final
Component: - Select a component Version: Tor: 0.2.9.12
Severity: Normal Keywords: tor router
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have configuration on raspberry pi 3 for tor router but i have problem in tor configuration
i have this error

Feb 18 05:57:19.769 [notice] Tor 0.2.9.12 (git-2b1e823d7bc05a37) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.1.0f and Zlib 1.2.8.
Feb 18 05:57:19.769 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Feb 18 05:57:19.769 [notice] Read configuration file "/etc/tor/torrc".
Feb 18 05:57:19.780 [warn] The TransListenAddress option is deprecated, and will most likely be removed in a future version of Tor. Use TransPort instead. (If you think this is a mistake, please let us know!)
Feb 18 05:57:19.780 [warn] The DNSListenAddress option is deprecated, and will most likely be removed in a future version of Tor. Use DNSPort instead. (If you think this is a mistake, please let us know!)
Feb 18 05:57:19.780 [notice] You configured a non-loopback address '192.168.42.1:53' for DNSPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Feb 18 05:57:19.780 [notice] You configured a non-loopback address '192.168.42.1:9040' for TransPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Feb 18 05:57:19.783 [notice] You configured a non-loopback address '192.168.42.1:53' for DNSPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Feb 18 05:57:19.783 [notice] You configured a non-loopback address '192.168.42.1:9040' for TransPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Feb 18 05:57:19.783 [notice] Opening Socks listener on 127.0.0.1:9050
Feb 18 05:57:19.783 [warn] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
Feb 18 05:57:19.783 [notice] Opening DNS listener on 192.168.42.1:53
Feb 18 05:57:19.783 [warn] Could not bind to 192.168.42.1:53: Permission denied
Feb 18 05:57:19.783 [notice] Opening Transparent pf/netfilter listener on 192.168.42.1:9040
Feb 18 05:57:19.783 [warn] Could not bind to 192.168.42.1:9040: Address already in use. Is Tor already running?
Feb 18 05:57:19.783 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Feb 18 05:57:19.783 [err] Reading config failed--see warnings above.

the tor service is blocked in turkey
Attached torrc file
please advice

Child Tickets

Attachments (1)

torrc.tar.gz (6.0 KB) - added by osos 22 months ago.

Download all attachments as: .zip

Change History (2)

Changed 22 months ago by osos

Attachment: torrc.tar.gz added

comment:1 Changed 22 months ago by dgoulet

Resolution: not a bug
Status: newclosed

Hi,

You need to run your tor as root user to be able to bind to port 53.

Furthermore, it seems something is already running on port 9040 and 9050 which explains the:

Feb 18 05:57:19.783 [warn] Could not bind to 192.168.42.1:9040: Address already in use. Is Tor already running?

I think you should see if tor is already running, killing it and using root to be able to bind to 53.

Note: See TracTickets for help on using tickets.