#25379 closed task (duplicate)

Determine the lowest rustc version we will compile with

Reported by: isis Owned by:
Priority: Low Milestone: Tor: 0.3.5.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: rust, tor-build
Cc: Actual Points:
Parent ID: #24765 Points: 2
Reviewer: Sponsor: SponsorM-can

Description

In our docs, we say that we currently develop with nightly, and that we might stop doing that soon. In our Makefiles, we refuse to compile if rustc is <1.14. About a week ago, some of us were pretty excited that the current stable compiler (1.24) will now abort if a panic occurs at an FFI boundary. Also, our Makefiles currently contain a linker workaround for OSX systems for rustc <1.24 (#25341).

We should maaaaaybe narrow down which version(s) of Rust we're using?

Child Tickets

Change History (2)

comment:1 Changed 15 months ago by teor

Parent ID: #24765

This might be a duplicate of #24765

comment:2 in reply to:  1 Changed 15 months ago by isis

Resolution: duplicate
Status: newclosed

Replying to teor:

This might be a duplicate of #24765


Definitely a duplicate, thanks!

Note: See TracTickets for help on using tickets.