#25396 closed defect (fixed)

Consensus health reports wrong latest valid-after time

Reported by: asn Owned by: tom
Priority: Medium Milestone:
Component: Metrics/Consensus Health Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Over the past days a few people have reported that consensus health reports the wrong latest valid-after time.

As an example, it currently says:

Consensus was published 2018-03-01 17:00:00. Note that it takes up to 15 minutes to learn about new consensus and votes and process them.

but there is a valid 19:00 consensus:

$ curl -kis http://199.58.81.140/tor/status-vote/current/consensus-microdesc | grep valid-after
valid-after 2018-03-01 19:00:00
$ date --utc
Thu  1 Mar 19:33:43 UTC 2018

Child Tickets

Change History (2)

comment:1 Changed 19 months ago by tom

It's possible this is caused by host issues. The host that it runs on is currently down, which is why it says 2018-03-01 17:00:00 as of this comment.

comment:2 Changed 18 months ago by tom

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.