Opened 17 months ago

Closed 17 months ago

Last modified 16 months ago

#25401 closed defect (duplicate)

Transparent proxy stopped working after Linux kernel update to version 4.4.118 that fixes Spectre variant 1

Reported by: FlinchX Owned by:
Priority: High Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version: Tor: 0.3.2.9
Severity: Major Keywords:
Cc: adrelanos@… Actual Points:
Parent ID: #25380 Points:
Reviewer: Sponsor:

Description

This happens on a fully updated Slackware64-14.2 system with tor 0.3.2.9 after an update to kernel 4.4.118 that fixes Spectre variant 1. Same version of tor worked fine with a few previous 4.4.x kernel versions (4.4.115, 4.4.111, 4.4.88). Tor process freezes in uninterruptible state as soon as a program anonymized using this guideline https://trac.torproject.org/projects/tor/wiki/doc/TransparentProxy#Transparentlyanonymizingtrafficforaspecificuser tries to get online. Symptoms are similar to the ones described in this ticket https://trac.torproject.org/projects/tor/ticket/25380

More technical details from two different sources that were able to reproduce the issue independently can be found in this forum thread https://www.linuxquestions.org/questions/slackware-14/address-already-in-use-errors-when-trying-to-restart-tor-4175624554/

Child Tickets

Change History (2)

comment:1 Changed 17 months ago by teor

Keywords: transparent proxy TransPort removed
Milestone: Tor: 0.3.3.x-final
Parent ID: #25380
Priority: ImmediateHigh
Resolution: duplicate
Severity: BlockerMajor
Status: newclosed

Looks like this is a duplicate of #25380

comment:2 Changed 16 months ago by adrelanos

Cc: adrelanos@… added
Note: See TracTickets for help on using tickets.