Opened 3 months ago

Closed 3 months ago

#25426 closed defect (invalid)

Failure to download Tor Browser (curl --tlsv1.2 fail)

Reported by: 0brand Owned by: tpa
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Major Keywords:
Cc: adrelanos@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Whonix- Attempting to download Tor Browser from https://www.torproject.org/projects/torbrowser/RecommendedTBBVersion fails using curl --tlsv1.2 with error.

curl: (35) error:14077102:SSL routines:SSL23_GET_SERVER_HELLO:unsupported protocol

However, lower TLS version curl --tlsv1.0 is working when downloading from https://www.torproject.org/projects/torbrowser/RecommendedTBBVersions

Child Tickets

Change History (4)

comment:1 Changed 3 months ago by adrelanos

Cc: adrelanos@… added
Component: - Select a componentInternal Services/Tor Sysadmin Team
Owner: set to tpa

comment:2 Changed 3 months ago by adrelanos

Failing:

curl --tlsv1.2 https://www.torproject.org/projects/torbrowser/RecommendedTBBVersions

curl: (35) error:14077102:SSL routines:SSL23_GET_SERVER_HELLO:unsupported protocol


Working, but low TLS version:

curl --tlsv1.0 https://www.torproject.org/projects/torbrowser/RecommendedTBBVersion

--tlsv1.2 was working previously. The TLS downgrade was done around 26 Feb 2018. So this is a regression.

comment:3 in reply to:  description Changed 3 months ago by 0brand

Replying to 0brand:

Attempting to download Tor Browser from https://www.torproject.org/projects/torbrowser/RecommendedTBBVersion fails using curl --tlsv1.2 with error.

curl: (35) error:14077102:SSL routines:SSL23_GET_SERVER_HELLO:unsupported protocol

However, lower TLS version curl --tlsv1.0 is working when downloading from https://www.torproject.org/projects/torbrowser/RecommendedTBBVersions

Removed "Whonix" from description. Is not Whonix specific issue

Last edited 3 months ago by 0brand (previous) (diff)

comment:4 Changed 3 months ago by teor

Keywords: Tor Browser Download SSL failure curl --tlsv1.2 removed
Resolution: invalid
Status: newclosed

This is a duplicate of #25418, which is being resolved with the provider.

Note: See TracTickets for help on using tickets.