Opened 5 months ago

Closed 5 months ago

#25452 closed defect (duplicate)

FAIL ../src/test/test_hs_service.c:420: assert(ip->time_to_expire OP_GE now + INTRO_POINT_LIFETIME_MIN_SECONDS + 5)

Reported by: asn Owned by:
Priority: Medium Milestone: Tor: 0.3.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs tor-test
Cc: dgoulet Actual Points:
Parent ID: Points: 0.2
Reviewer: Sponsor:

Description

weasel reported the test_service_intro_point() test failing here:

    ip = helper_create_service_ip();
    tt_assert(ip);
    /* Make sure the authentication keypair is not zeroes. */
    tt_int_op(tor_mem_is_zero((const char *) &ip->auth_key_kp,
                              sizeof(ed25519_keypair_t)), OP_EQ, 0);
    /* The introduce2_max MUST be in that range. */
    tt_u64_op(ip->introduce2_max, OP_GE,
              INTRO_POINT_MIN_LIFETIME_INTRODUCTIONS);
    tt_u64_op(ip->introduce2_max, OP_LE,
              INTRO_POINT_MAX_LIFETIME_INTRODUCTIONS);
    /* Time to expire MUST also be in that range. We add 5 seconds because
     * there could be a gap between setting now and the time taken in
     * service_intro_point_new. On ARM, it can be surprisingly slow... */
    tt_u64_op(ip->time_to_expire, OP_GE,
              now + INTRO_POINT_LIFETIME_MIN_SECONDS + 5);
    tt_u64_op(ip->time_to_expire, OP_LE,
              now + INTRO_POINT_LIFETIME_MAX_SECONDS + 5);

Child Tickets

Change History (2)

comment:1 Changed 5 months ago by weasel

duplicate of #25450?

comment:2 in reply to:  1 Changed 5 months ago by asn

Resolution: duplicate
Status: newclosed

Replying to weasel:

duplicate of #25450?

Yes, I missed that one. Thanks! :)

Note: See TracTickets for help on using tickets.