Opened 5 months ago

Closed 3 months ago

#25458 closed defect (fixed)

UI customization half-broken in Tor Browser 8.0a3

Reported by: viktorj Owned by: pospeselr
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-regression, TorBrowserTeam201804R
Cc: franklin, tbb-team Actual Points:
Parent ID: #25147 Points:
Reviewer: Sponsor:

Description

seen with Tor Browser 8.0a3-build1 on Linux (64 bit)

Changing the UI via the menu entry "Customize" does not work anymore because the customization view closes immediately after opening, so drag-and-drop is impossible. Right-clicking on a menu entry and selecting "Move to Toolbar" still works, as well as "Move to Menu" for something which was moved to the toolbar.

Maybe #25147 is the reason.

Child Tickets

Attachments (1)

0001-Bug-25458-UI-customization-half-broken-in-Tor-Browse.patch (1.9 KB) - added by pospeselr 3 months ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 4 months ago by cypherpunks

Keywords: tbb-regression added
Parent ID: #25147
Priority: MediumHigh
Severity: NormalMajor

You shipped it, ignoring tor-qa, so hrm...

comment:2 Changed 4 months ago by cypherpunks

Strange, I can't reproduce the issue myself (linux 64 bit as well)...

comment:3 Changed 4 months ago by cypherpunks

Reproducible on Windows:

16:54:02.700 CustomizeMode:Error entering customize mode TypeError: messageNode.querySelector(...) is null
Stack trace:
CustomizeMode.prototype.maybeShowTip@resource:///modules/CustomizeMode.jsm:701:7
CustomizeMode.prototype.enter/<@resource:///modules/CustomizeMode.jsm:358:7
TaskImpl_run@resource://gre/modules/Task.jsm:319:42
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:932:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747:11
 1 CustomizeMode.jsm:374

comment:4 Changed 4 months ago by gk

Keywords: TorBrowserTeam201803 added

comment:5 Changed 4 months ago by cypherpunks

Yeah, I can reproduce it now with a fresh clean install of Tor Browser 8.0a4

comment:6 Changed 4 months ago by franklin

Cc: franklin added

comment:7 Changed 4 months ago by cypherpunks

Not sure how related but BTW the entire UI becomes sometimes completely unresponsive, and one has to wait quiet a bit before it gets back to normal.

comment:8 Changed 4 months ago by gk

Keywords: TorBrowserTeam201804 added; TorBrowserTeam201803 removed

Moving our tickets to April.

comment:9 Changed 4 months ago by gk

Priority: HighMedium

comment:10 Changed 3 months ago by pospeselr

Owner: changed from tbb-team to pospeselr
Status: newassigned

comment:11 Changed 3 months ago by boklm

Cc: tbb-team added

comment:12 Changed 3 months ago by pospeselr

Keywords: TorBrowserTeam201804R added; TorBrowserTeam201804 removed
Status: assignedneeds_review

comment:13 Changed 3 months ago by gk

Status: needs_reviewneeds_information

So, that fix in grid.js is not directly related to the customization basically broken, right? Or, if it *is* related to that how do I trigger that breakage, because it seems I am failing to do so.

comment:14 Changed 3 months ago by pospeselr

Status: needs_informationneeds_review

comment:15 Changed 3 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good now, thanks. Applied to tor-browser-52.7.3esr-8.0-1 (commit 12847934f5c7baf4e94945ec433f1b2fdcf33625).

Note: See TracTickets for help on using tickets.