Opened 3 months ago

Closed 3 months ago

#25465 closed defect (duplicate)

Transparent proxy hangs after kernel update to 4.15.6-200.fc26.x86_64

Reported by: freerj Owned by:
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version: Tor: 0.3.2.9
Severity: Normal Keywords: 033-must, hang, 032-backport, 031-backport-maybe, 029-backport-maybe, 025-backport-maybe
Cc: adrelanos@… Actual Points:
Parent ID: #25380 Points:
Reviewer: Sponsor:

Description

Long running stable router box (FC26), tor transparent proxy has been working great for years. Tor now crashes and hangs when application attempts to connect through transparent proxy (TransProxy 9040) etc:

# ps -auxf | grep toranon
toranon 2479 0.1 0.2 80920 34640 ? Ds 19:45 0:00 /usr/bin/tor --runasdaemon 0 --defaults-torrc /usr/share/tor/defaults-torrc -f /etc/tor/torrc

Attempted to downgrade tor back to 0.2.9.10 with dnf... No joy.

Attempted to downgrade openssl to 1.1.0f-4... No joy

When I attempt to connect, say with curl, the last 2 lines in debug.log are:

Mar 11 20:06:20.000 [debug] connection_add_impl(): new conn type Socks, socket 16, address 172.16.111.3, n_conns 7.
Mar 11 20:06:20.000 [debug] connection_ap_process_transparent(): entered.

curl hangs, tor hangs (STATUS Ds), have to reboot to clear it.

Suggestions welcome.

Child Tickets

Change History (1)

comment:1 Changed 3 months ago by cypherpunks

Resolution: duplicate
Status: newclosed

I guess this is a duplicate of #25380

Note: See TracTickets for help on using tickets.