Opened 3 months ago

Last modified 3 months ago

#25467 needs_information defect

failing to read userChrome.css

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB 7.5, Linux.

Tested on fresh, unmodified bundle, separately tested in safe mode.

Browser fails to recognize userChrome.css and any modifications therein.

Child Tickets

Attachments (1)

userChrome.css (102 bytes) - added by gk 3 months ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 3 months ago by gk

Keywords: userChrome.css removed
Status: newneeds_information
Type: taskdefect

Could you give us more detailed steps to reproduce your issue and possibly an example userChrome.css?

comment:2 Changed 3 months ago by cypherpunks

A dark theme is in use on the desktop, and all of the bookmark separators in TBB have become invisible. I've tried:

menupopup menuseparator {

-moz-appearance: none !important;
border-color: grey !important;

}

The above works immediately, both with and without the @namespace line, in Firefox ESR 52.6.0.

Other scripts were also tried, but this one was the only one working in FF 52 ESR.

comment:3 Changed 3 months ago by cypherpunks

I'll try to confirm what the cypherpunks above said,

  1. cd tor-browser_en-US/Browser/TorBrowser/Data/Browser/profile.default
  2. mkdir chrome
  3. cd chrome
  4. nano userChrome.css
  5. Put the things he mentioned (I put in red since I can't notice the change with just grey and I don't know what the result will look like)
    menupopup menuseparator {
    
        -moz-appearance: none !important;
        border-color: red !important;
    
    }
    
  6. Save.
  7. Oppened the Tor Browser, went to the bookmarks popup but found nothing red, searched for something red inside the menu but found nothing, so he's probably right. Also running ./start-tor-browser --debug showed nothing relevant.

So maybe she's right, but she should explain to me whether my procedure was correct :)

Last edited 3 months ago by cypherpunks (previous) (diff)

comment:4 Changed 3 months ago by cypherpunks

Your process was correct. It would also be helpful to know what version of the TBB you are using, and for you to also test this process on the same Ff version I did, i.e. ESR 52.6.0.

Side note: I'm not a he.

comment:5 in reply to:  4 Changed 3 months ago by cypherpunks

Replying to cypherpunks:

Your process was correct. It would also be helpful to know what version of the TBB you are using, and for you to also test this process on the same Ff version I did, i.e. ESR 52.6.0.

I was using 8.0a3. Will test on it later.

Side note: I'm not a he.

I apologize, I corrected my comment.

comment:6 in reply to:  3 Changed 3 months ago by gk

Resolution: worksforme
Status: needs_informationclosed

Replying to cypherpunks:

I'll try to confirm what the cypherpunks above said,

  1. cd tor-browser_en-US/Browser/TorBrowser/Data/Browser/profile.default
  2. mkdir chrome
  3. cd chrome
  4. nano userChrome.css
  5. Put the things he mentioned (I put in red since I can't notice the change with just grey and I don't know what the result will look like)
    menupopup menuseparator {
    
        -moz-appearance: none !important;
        border-color: red !important;
    
    }
    
  6. Save.
  7. Oppened the Tor Browser, went to the bookmarks popup but found nothing red, searched for something red inside the menu but found nothing, so he's probably right. Also running ./start-tor-browser --debug showed nothing relevant.

So maybe she's right, but she should explain to me whether my procedure was correct :)

This works for me on a Linux box if I add the bookmarks item to the toolbar as it is the case in my vanilla Firefox 52. The menuseparators are shown in red. Please reopen this ticket if you still think there is an actual bug. Steps to reproduce (and a respective userChrome.css) would be greatly appreciated.

comment:7 Changed 3 months ago by cypherpunks

Resolution: worksforme
Status: closedreopened

I don't know what to tell you, it still does not work for me.

@Gk, were you testing on the version of the Browser Bundle that I listed?

I really don't know how we could be getting different experiences since I'm working with a clean, unmodified TBB.

What else can I do to document this for you?

comment:8 in reply to:  7 Changed 3 months ago by gk

Status: reopenedneeds_information

Replying to cypherpunks:

I don't know what to tell you, it still does not work for me.

@Gk, were you testing on the version of the Browser Bundle that I listed?

With different ones in fact. Just retested with a clean, new 7.5.3 on a Debian testing machine with XFCE.

I really don't know how we could be getting different experiences since I'm working with a clean, unmodified TBB.

What else can I do to document this for you?

Good question. Here is what I did. I followed the steps in comment:3 up to and including step 6. Step 7 for me is: opening Tor Browser and adding the bookmark item to my toolbar. 8. Opening the bookmark popup on the toolbar and the menuseparators are red. I'll add my userChome.css to this ticket. Could you retry following my steps?

Changed 3 months ago by gk

Attachment: userChrome.css added

comment:9 Changed 3 months ago by cypherpunks

Here's something Interesting: in the interval I've upgraded firefox to 52.7.3 ESR, and now it doesn't work in firefox, either.

And yes, still does not work in TBB Linux64 7.5.3.

DE this whole session has been lxde. I've tried a lot of different themes for both the DE in geneal and the window manager in specific, and no difference is made.

In fact, separators are invisible both before and after the userChrome.css is added, except in the bookmarks toolbar. In the bookmarks toolbar, separators do appear clearly, but are not affected by the userChrome.css, i.e. they are not red.

Seems like possibly a Mozilla bug now, and I do not look forward to trying to deal with them about this :(

Last edited 3 months ago by cypherpunks (previous) (diff)

comment:10 Changed 3 months ago by cypherpunks

Okay, some more poking around contradicts my above statement:

In fact, separators are invisible both before and after the userChrome.css is added

in that it turns out, in firefox, the menu separators are only invisible when the userChrome.css file is in the chrome folder.

As was said even further above:

The above works immediately, both with and without the @namespace line, in Firefox ESR 52.6.0.

Something changed in FF from 52.6.0 to 52.7.3 possibly?

TBB behavior, to stay clear, does not show menu separators regardless of whether there is this userChrome.css file or not.

Note: See TracTickets for help on using tickets.