Opened 9 months ago

Closed 9 months ago

#25474 closed defect (fixed)

configure test for libevent fails with c99

Reported by: nickm Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 033-backport 032-backport regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When c99 self-enables with no flags, then our libevent tests fail, because they don't always include a function prototype for event_base_free. This is a bug caused by our bugfix for #24279 in 0.3.2.5-alpha.

Child Tickets

Change History (4)

comment:1 Changed 9 months ago by nickm

Keywords: regression added

comment:2 Changed 9 months ago by nickm

Status: assignedneeds_review

bug25474_032 has a one-line bugfix :)

comment:3 Changed 9 months ago by ahf

Status: needs_reviewmerge_ready

Patch looks good to me.

comment:4 Changed 9 months ago by nickm

Milestone: Tor: 0.3.3.x-finalTor: 0.3.2.x-final
Resolution: fixed
Status: merge_readyclosed

Thanks! Merged to 0.3.2 and forward.

Note: See TracTickets for help on using tickets.