Opened 4 months ago

Closed 4 months ago

#25479 closed defect (fixed)

Fix win32 crash in bench.c

Reported by: isis Owned by:
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version: Tor: 0.2.6.1-alpha
Severity: Normal Keywords: windows, tor-tests, 033-must, review-group-36
Cc: Actual Points:
Parent ID: Points: .2
Reviewer: isis Sponsor:

Description

On the mailing lists, Gisle Vanem reported a crash while running bench.exe on a windows system. On first sight, it appeared to be possibly related to calling options_new() from bench.c's main(), but Gisle provided a patch which reportedly fixes the crash by calling init_protocol_warning_severity_level() which instead suggests that the crash was due to calling init_logging() (which calls tor_mutex_init(), which then calls InitializeCriticalSection()). The MSDN documentation for InitializeCriticalSection() states that has slightly different behaviours during edge cases for different windows flavours, so that could possibly have been the cause of the issue?

Child Tickets

Change History (5)

comment:1 Changed 4 months ago by isis

Status: newneeds_review

If someone who knows windows better could take a second look at this, that would be great!

comment:2 Changed 4 months ago by nickm

This patch seems reasonable. It just needs a changes file. I think that this bug was introduced during 0.3.3.2-alpha when we fixed #23954.

comment:3 Changed 4 months ago by nickm

Status: needs_reviewmerge_ready

comment:4 Changed 4 months ago by isis

Okay, the applied patch and changes file is in my bug25479 branch.

comment:5 Changed 4 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

Cool; cherry-picked to 0.3.3 and merged forward!

Note: See TracTickets for help on using tickets.