Opened 5 months ago

Closed 5 months ago

#25508 closed enhancement (duplicate)

Expose Tor's RNG to Rust

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: roadmap, rust, rng
Cc: catalyst, isis, nickm, teor, chelseakomlo Actual Points:
Parent ID: Points:
Reviewer: Sponsor: SponsorQ

Description

To get privcount working happily in Tor, we need a CSPRNG. For consistency across languages, we should expose Tor's crypto_rand() as a Rust rand::Rng.

Child Tickets

Change History (4)

comment:1 Changed 5 months ago by chelseakomlo

Cc: chelseakomlo added

comment:2 Changed 5 months ago by nickm

Milestone: Tor: 0.3.3.x-finalTor: 0.3.4.x-final

comment:3 Changed 5 months ago by isis

Possible duplicate of #24660?

comment:4 Changed 5 months ago by isis

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.