Opened 4 weeks ago

Closed 3 weeks ago

#25617 closed defect (fixed)

unable to resolve DNS requests from control port, regression

Reported by: starlight Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version: Tor: 0.3.3.3-alpha
Severity: Normal Keywords: regression, tor-dns, tor-control, 033-must, 029-backport 031-backport 032-backport
Cc: Actual Points:
Parent ID: Points:
Reviewer: dgoulet Sponsor:

Description

setevents addrmap
250 OK

resolve blog.torproject.org
250 OK
650 ADDRMAP blog.torproject.org <error> "2018-03-25 08:39:54" error=yes EXPIRES="2018-03-25 12:39:54" CACHED="NO"
Mar 25 08:39:55 Tor[]: Refusing to connect to hostname [scrubbed] because Port has NoDNSRequest set.

Child Tickets

Change History (10)

comment:1 Changed 4 weeks ago by arma

I can confirm that the above sequence happens as described -- in master and in maint-0.2.9.

You say regression -- can you remind us when this used to work? :)

Last edited 4 weeks ago by arma (previous) (diff)

comment:2 Changed 4 weeks ago by starlight

er, not sure. . .2.6.something?

Seems to me client DNS was extensively renovated along the way with an eye toward IPv6. SocksPort flag NoDNSRequest is new and related I think. Perhaps +DNSRequest or -NoDNSRequest applied invisibly to control ports would fix?

comment:3 Changed 3 weeks ago by dgoulet

Keywords: regression tor-dns tor-control 033-must added
Milestone: Tor: 0.3.3.x-final

Possible regression thus marking it for proposed inclusion in 033.

comment:4 Changed 3 weeks ago by arma

Looks like that feature went into 0.2.9.3-alpha, as part of #18693.

comment:5 Changed 3 weeks ago by arma

Looks like the fix should go in dnsserv_launch_request() down when we're messing with entry_conn->entry_cfg.

comment:6 Changed 3 weeks ago by nickm

Owner: set to nickm
Status: newaccepted

This is a one-line fix fwict

comment:7 Changed 3 weeks ago by nickm

Keywords: 029-backport 031-backport 032-backport added
Status: acceptedneeds_review

bug25617_029 is a fix here; it works fine for me.

comment:8 Changed 3 weeks ago by dgoulet

Reviewer: dgoulet
Status: needs_reviewmerge_ready

Also works for me!

RESOLVE test.com
250 OK
650 ADDRMAP test.com 69.172.200.235 "2018-03-29 11:23:34" EXPIRES="2018-03-29 15:23:34" CACHED="

comment:9 Changed 3 weeks ago by arma

I think for this one we could happily put the fix into 0.3.3 and not do backports. It is indeed broken in earlier versions, but it has been for a long time, and this is the first we noticed, and also it's kind of an 'expert' feature.

comment:10 Changed 3 weeks ago by nickm

Resolution: fixed
Status: merge_readyclosed

Merged to 0.3.3. Not marking for backport, per my inclination and Roger's recommendation.

Note: See TracTickets for help on using tickets.