#25677 closed defect (duplicate)

Tor startup crash with Sandbox 1 in torrc.d - sandbox_intern_string(): Bug: No interned sandbox parameter found

Reported by: adrelanos Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor Version:
Severity: Normal Keywords:
Cc: whonix-devel@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor from deb.torproject.org. Inside Whonix 14.

dpkg -l | grep tor

ii  tor                                           0.3.2.10-1~d90.stretch+1                   amd64        anonymizing overlay network for TCP
user@host:~$ cat /etc/tor/torrc
## Do not edit this file!
## Please create and add modifications to the following file instead:
## /usr/local/etc/torrc.d/50_user.conf

%include /etc/torrc.d/95_whonix.conf
user@host:~$ cat /etc/torrc.d/95_whonix.conf
## Do not edit this file!
## Please create and add modifications to the following file instead:
## /usr/local/etc/torrc.d/50_user.conf
%include /usr/local/etc/torrc.d/40_anon_connection_wizard.conf
%include /usr/local/etc/torrc.d/50_user.conf
user@host:~$ cat /usr/local/etc/torrc.d/40_anon_connection_wizard.conf
# This file is generated by and should ONLY be used by anon-connection-wizard.
# User configuration should go to /usr/local/etc/torrc.d/50_user.conf, not here. Because:
#    1. This file can be easily overwritten by anon-connection-wizard.
#    2. Even a single character change in this file may cause error.
# However, deleting this file will be fine since a new plain file will be generated the next time you run anon-connection-wizard.
DisableNetwork 0
user@host:~$ cat /usr/local/etc/torrc.d/50_user.conf
Sandbox 1
Mar 30 06:14:28 host Tor[5429]: Opening DNS listener on 10.137.11.1:5300
Mar 30 06:14:28 host Tor[5429]: Opening DNS listener on 127.0.0.1:5400
Mar 30 06:14:28 host Tor[5429]: Opening Transparent pf/netfilter listener on 10.137.11.1:9040
Mar 30 06:14:28 host Tor[5429]: Opening Transparent pf/netfilter listener on 127.0.0.1:9041
Mar 30 06:14:28 host Tor[5429]: Parsing GEOIP IPv4 file /usr/share/tor/geoip.
Mar 30 06:14:28 host Tor[5429]: Parsing GEOIP IPv6 file /usr/share/tor/geoip6.
Mar 30 06:14:28 host Tor[5429]: Bootstrapped 0%: Starting
Mar 30 06:14:28 host Tor[5429]: Starting with guard context "default"
Mar 30 06:14:28 host Tor[5429]: Bootstrapped 80%: Connecting to the Tor network
Mar 30 06:14:28 host Tor[5429]: Signaled readiness to systemd
Mar 30 06:14:28 host Tor[5429]: Received reload signal (hup). Reloading config and resetting internal state.
Mar 30 06:14:28 host Tor[5429]: Read configuration file "/usr/share/tor/tor-service-defaults-torrc".
Mar 30 06:14:28 host Tor[5429]: Read configuration file "/etc/tor/torrc".
Mar 30 06:14:29 host Tor[5429]: sandbox_intern_string(): Bug: No interned sandbox parameter found for /etc/torrc.d/95_whonix.conf (on Tor 0.3.2.10 )
Mar 30 06:14:29 host systemd[1]: Started Anonymizing overlay network for TCP.
Mar 30 06:14:29 host Tor[5429]: sandbox_intern_string(): Bug: No interned sandbox parameter found for /etc/torrc.d/95_whonix.conf (on Tor 0.3.2.10 )
Mar 30 06:14:29 host Tor[5429]: Could not open "/etc/torrc.d/95_whonix.conf": Permission denied
Mar 30 06:14:29 host Tor[5429]: Error reading included configuration file or directory: "/etc/torrc.d/95_whonix.conf".
Mar 30 06:14:29 host Tor[5429]: Reading config failed--see warnings above. For usage, try -h.
Mar 30 06:14:29 host Tor[5429]: Restart failed (config error?). Exiting.
Mar 30 06:14:29 host systemd[1]: tor@default.service: Main process exited, code=exited, status=1/FAILURE

Child Tickets

Change History (2)

comment:1 Changed 11 months ago by iry

Cc: whonix-devel@… added

comment:2 Changed 11 months ago by nickm

Milestone: Tor: 0.3.2.x-final
Resolution: duplicate
Status: newclosed

This looks like a duplicate of #22605 , which was supposed to be fixed in 0.3.3.1-alpha ; please reopen if it isn't?

Note: See TracTickets for help on using tickets.