#25682 closed enhancement (duplicate)

Obsolete Tor Core Encryption, Only use SHA3/ed25519/curve25519 for building Circuits

Reported by: Anony Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

a) Better crypto (replaced SHA1/DH/RSA1024 with SHA3/ed25519/curve25519)

Don't allow New Tor nodes to build circuits with obsolete Tor Nodes unless they support the newer encryption version 0.3.2.9 - 2018-01-09

Only use the old crypto to resolve old .Onion honeypots...........

Only use SHA3/ed25519/curve25519 to build New 3 hop Circuits. This will provide better anon for hidden services which use the same transport system.

Child Tickets

Change History (2)

comment:1 Changed 14 months ago by cypherpunks

Priority: ImmediateMedium
Severity: CriticalNormal

comment:2 Changed 14 months ago by teor

Milestone: Tor: unspecified
Resolution: duplicate
Status: newclosed
Version: Tor: unspecified

This is a duplicate of #25662, which has been closed, because we already have plans for these changes.

Please stop posting duplicate tickets.

Note: See TracTickets for help on using tickets.