Opened 8 months ago

Closed 4 months ago

#25735 closed defect (fixed)

Tor Browser stalls while loading Facebook login page (Waiting for static.xx.fbcdn.net)

Reported by: uzi Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-usability-website, ff60-esr, tbb-performance
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Problem:
After opening the Tor Browser and typing in facebook.com, page loading hangs, status bar showing "Waiting for static.xx.fbcdn.net"

HTTP GET requests for small images from static.xx.fbcdn.net stall in the "Blocked" state for minutes - viewed in Developer tools / Network / request / Timing (see attached screenshot Step2.png).

When a different website is opened in a new tab, HTTP requests continue loading successfully - seems to be some livelock within the browser.

This is not a network issue, connectivity in the browser works fine, also verifed without a SOCKS proxy (direct connection without Tor).

Reproducibility: nearly 100%

Environment:

  • Windows 10 Pro, 64bit
  • Tor Browser 7.5.3 for Windows, english
  • Tor Browser 8.0a5 for Windows, english

Child Tickets

Attachments (2)

Step1.png (152.4 KB) - added by uzi 8 months ago.
Stalled browser loading Facebook
Step2.png (180.3 KB) - added by uzi 8 months ago.
Un-stalled again

Download all attachments as: .zip

Change History (18)

Changed 8 months ago by uzi

Attachment: Step1.png added

Stalled browser loading Facebook

Changed 8 months ago by uzi

Attachment: Step2.png added

Un-stalled again

comment:1 Changed 8 months ago by Ga15

Works for me at win10 pro.

comment:2 Changed 8 months ago by uzi

Exact same behavior:

  • on a different machine with Windows 7
  • with a different internet connection

comment:3 Changed 8 months ago by gk

Keywords: tbb-usability-website added
Status: newneeds_information

Hm, I wonder what's up here. Do you have some antivirus/firewall tool that could be interfering? If so, could you uninstall it for a test (disabling is often not enough) and see if that fixes your issue?

comment:4 Changed 8 months ago by cypherpunks

In the meantime you can use the Facebook onion service https://facebookcorewwwi.onion/ which doesn't have this issue (hopefully).

comment:5 Changed 8 months ago by uzi

Tried on a third machine, Win 7, another internet connection, antivirus uninstalled, no firewall - same behavior.

Am I really the only one who experiences this?

comment:6 in reply to:  5 Changed 8 months ago by cypherpunks

Replying to uzi:

Tried on a third machine, Win 7, another internet connection, antivirus uninstalled, no firewall - same behavior.

Did you try with https://facebookcorewwwi.onion/?

comment:8 Changed 8 months ago by cypherpunks

Status: needs_informationnew

Reproducibility: nearly 100%

And thanks for the detailed description. It's up to developers now to find out what's up.

comment:9 Changed 8 months ago by cypherpunks

I wonder whether this is a duplicate of/related to #21924, gk says there:

This change e.g. if I go to Trac in a new tab. Suddenly the icon on the former tab stops spinning and all is fine. This happens at least with a 64bit Linux.

(Sorry for the vague bug report :) )

Which seems to be the same case here (except the bug report is more precise :) ).

comment:10 Changed 8 months ago by cypherpunks

Maybe bugs like these can be simulated with a firejail --bandwidth=torbrowser set eth0 5 6 or worse, I don't know, but it seems like this is due to static.xx.fbcdn.net being overloaded by exits, and it took time to load up and something weird happened. If I recall trac.tp.o had also some overloading issues at the time, maybe that's why gk was experiencing a similar bug at the time.

comment:11 in reply to:  10 ; Changed 8 months ago by gk

Status: newneeds_information

Replying to cypherpunks:

Maybe bugs like these can be simulated with a firejail --bandwidth=torbrowser set eth0 5 6 or worse, I don't know, but it seems like this is due to static.xx.fbcdn.net being overloaded by exits, and it took time to load up and something weird happened. If I recall trac.tp.o had also some overloading issues at the time, maybe that's why gk was experiencing a similar bug at the time.

Good idea, but I think it's something different here. OP: does it help if you flip network.http.spdy.enabled and network.http.spdy.enabled.http2 to true (just for testing purposes)?

comment:12 in reply to:  11 ; Changed 8 months ago by uzi

Replying to gk:

OP: does it help if you flip network.http.spdy.enabled and network.http.spdy.enabled.http2 to true (just for testing purposes)?

It indeed does help - facebook loads instantly.

Important remark reiterated: the problem also happens when not connecting via Tor (reconfigured Tor Browser to just use a plain proxy or no proxy at all).

comment:13 Changed 8 months ago by cypherpunks

Status: needs_informationnew

comment:14 in reply to:  12 Changed 8 months ago by gk

Keywords: ff60-esr added

Replying to uzi:

Replying to gk:

OP: does it help if you flip network.http.spdy.enabled and network.http.spdy.enabled.http2 to true (just for testing purposes)?

It indeed does help - facebook loads instantly.

Important remark reiterated: the problem also happens when not connecting via Tor (reconfigured Tor Browser to just use a plain proxy or no proxy at all).

Yes. It's not *Tor*-related but related to the above mentioned browser settings which are still active even if you configure a different proxy or none at all. We need #14952 sorted out first, to solve this problem which is supposed to happen soon.

comment:15 Changed 8 months ago by gk

Keywords: tbb-performance added

comment:16 Changed 4 months ago by gk

Resolution: fixed
Status: newclosed

Should be fixed with the changes made in commit 36724cc11e94d0dc3094c94f046d76fb5ce44a2b on tor-browser-60.1.0esr-8.0-1.

Note: See TracTickets for help on using tickets.