#25769 closed defect (duplicate)

Non-fatal assertion info failed in onion_extend_cpath at ../src/or/circuitbuild.c:2779.

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version: Tor: 0.3.3.4-alpha
Severity: Normal Keywords: relay, 034-must, 033-backport
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Relay on Debian 9:

 Self-testing indicates your ORPort is reachable from the outside. Excellent.
 tor_bug_occurred_(): Bug: ../src/or/circuitbuild.c:2779: onion_extend_cpath: Non-fatal assertion info failed. (on Tor 0.3.3.4-alpha )
 Bug: Non-fatal assertion info failed in onion_extend_cpath at ../src/or/circuitbuild.c:2779. Stack trace: (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(log_backtrace+0x44) [0x56222d382154] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x56222d39d989] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_establish_circuit+0x3b6) [0x56222d2d21c6] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_launch_by_extend_info+0x7d) [0x56222d2e569d] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(consider_testing_reachability+0x1ad) [0x56222d2932cd] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_send_next_onion_skin+0x372) [0x56222d2d1a82] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x7c391) [0x56222d275391] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_receive_relay_cell+0x31e) [0x56222d27738e] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(command_process_cell+0x170) [0x56222d2e8050] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(channel_tls_handle_cell+0x32b) [0x56222d2c84eb] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x1154d1) [0x56222d30e4d1] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x10bffe) [0x56222d304ffe] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x5371e) [0x56222d24c71e] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x6a0) [0x7f0920af65a0] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(do_main_loop+0x2bc) [0x56222d24d78c] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_run_main+0x275) [0x56222d24ee95] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_main+0x3a) [0x56222d2482da] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(main+0x19) [0x56222d248049] (on Tor 0.3.3.4-alpha )
 Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7f091f3522e1] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(_start+0x2a) [0x56222d24809a] (on Tor 0.3.3.4-alpha )
 Failed to find node for hop #2 of our path. Discarding this circuit.
 Self-testing indicates your DirPort is reachable from the outside. Excellent. Publishing server descriptor.
 tor_bug_occurred_(): Bug: ../src/or/circuitbuild.c:2390: onion_pick_cpath_exit: Non-fatal assertion !(exit_ei == NULL) failed. (on Tor 0.3.3.4-alpha )
 Bug: Non-fatal assertion !(exit_ei == NULL) failed in onion_pick_cpath_exit at ../src/or/circuitbuild.c:2390. Stack trace: (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(log_backtrace+0x44) [0x56222d382154] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x56222d39d989] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_establish_circuit+0xa22) [0x56222d2d2832] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_launch_by_extend_info+0x7d) [0x56222d2e569d] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_build_needed_circs+0x3c8) [0x56222d2e5e28] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x53c78) [0x56222d24cc78] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x6a0) [0x7f0920af65a0] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(do_main_loop+0x2bc) [0x56222d24d78c] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_run_main+0x275) [0x56222d24ee95] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_main+0x3a) [0x56222d2482da] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(main+0x19) [0x56222d248049] (on Tor 0.3.3.4-alpha )
 Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7f091f3522e1] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(_start+0x2a) [0x56222d24809a] (on Tor 0.3.3.4-alpha )
 tor_bug_occurred_(): Bug: ../src/or/circuitbuild.c:2390: onion_pick_cpath_exit: Non-fatal assertion !(exit_ei == NULL) failed. (on Tor 0.3.3.4-alpha )
 Bug: Non-fatal assertion !(exit_ei == NULL) failed in onion_pick_cpath_exit at ../src/or/circuitbuild.c:2390. Stack trace: (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(log_backtrace+0x44) [0x56222d382154] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x56222d39d989] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_establish_circuit+0xa22) [0x56222d2d2832] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_launch_by_extend_info+0x7d) [0x56222d2e569d] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_build_needed_circs+0x3c8) [0x56222d2e5e28] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x53c78) [0x56222d24cc78] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x6a0) [0x7f0920af65a0] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(do_main_loop+0x2bc) [0x56222d24d78c] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_run_main+0x275) [0x56222d24ee95] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_main+0x3a) [0x56222d2482da] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(main+0x19) [0x56222d248049] (on Tor 0.3.3.4-alpha )
 Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7f091f3522e1] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(_start+0x2a) [0x56222d24809a] (on Tor 0.3.3.4-alpha )



 tor_bug_occurred_(): Bug: ../src/or/circuitbuild.c:2779: onion_extend_cpath: Non-fatal assertion info failed. (on Tor 0.3.3.4-alpha )
 Bug: Non-fatal assertion info failed in onion_extend_cpath at ../src/or/circuitbuild.c:2779. Stack trace: (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(log_backtrace+0x44) [0x56222d382154] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_bug_occurred_+0xb9) [0x56222d39d989] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_establish_circuit+0x3b6) [0x56222d2d21c6] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_launch_by_extend_info+0x7d) [0x56222d2e569d] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(consider_testing_reachability+0x1ad) [0x56222d2932cd] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_send_next_onion_skin+0x372) [0x56222d2d1a82] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x7c391) [0x56222d275391] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(circuit_receive_relay_cell+0x31e) [0x56222d27738e] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(command_process_cell+0x170) [0x56222d2e8050] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(channel_tls_handle_cell+0x32b) [0x56222d2c84eb] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x1154d1) [0x56222d30e4d1] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x10bffe) [0x56222d304ffe] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(+0x5371e) [0x56222d24c71e] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x6a0) [0x7f0920af65a0] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(do_main_loop+0x2bc) [0x56222d24d78c] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_run_main+0x275) [0x56222d24ee95] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(tor_main+0x3a) [0x56222d2482da] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(main+0x19) [0x56222d248049] (on Tor 0.3.3.4-alpha )
 Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7f091f3522e1] (on Tor 0.3.3.4-alpha )
 Bug:     /usr/bin/tor(_start+0x2a) [0x56222d24809a] (on Tor 0.3.3.4-alpha )
 Failed to find node for hop #2 of our path. Discarding this circuit.

Child Tickets

Change History (2)

comment:1 Changed 12 months ago by catalyst

Keywords: 034-must 033-backport added
Milestone: Tor: 0.3.4.x-final

This seems to be the 0.3.3 version of #25692. The surrounding code is very similar; we just seem to have changed the assertion from info to info || client in 0.3.4. I'm not sure they're identical bugs though.

The !(exit_ei == NULL) assertion seems to be a duplicate of #25691.

comment:2 Changed 12 months ago by catalyst

Resolution: duplicate
Status: newclosed

After some discussion on IRC, I'm pretty sure this is a duplicate of #25691 and #25692 (both bugs seem to occur in this log). Cross-linked from the other tickets for reference.

Note: See TracTickets for help on using tickets.