Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#25778 closed defect (duplicate)

Secure Connection Failed with the Tor Browser

Reported by: greatormesby Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: paul.coltman7@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Steps to reproduce:
Version of TOR is 7.5.3

Went into TOR, trying to go into anything (even test network settings,duck duck go or any site) and it wont
I tried adding bridges (never needed before)
works fine directly from Firefox or chrome or IE

Actual results:

The connection to the server was reset while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

Learn more

Child Tickets

Change History (12)

comment:1 Changed 7 months ago by cypherpunks

works fine directly from Firefox or chrome or IE

What do you mean by this?

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

That's the crazy "Secure Connection Failed" warning, do you have Kaspersky or some other antivirus installed?

comment:2 Changed 7 months ago by cypherpunks

Component: Core TorApplications/Tor Browser
Keywords: connection reset removed
Milestone: Tor: unspecified
Owner: set to tbb-team
Summary: Can't access anything using TORSecure Connection Failed with the Tor Browser
Version: Tor: unspecified

comment:3 Changed 7 months ago by cypherpunks

Status: newneeds_information

comment:4 Changed 7 months ago by greatormesby

What I meant was I can access websites with any of the browsers mentioned but not with TOR.
I have tried with no anti virus software running and it is still the same
What is a bit worrying is the first time I tried it in windows 10 (after problem occurred in windows 7) it was fine but as soon as I tried to go back in the problem started to appear there as well.
Is this possibly something to do with Virgin Media blocking connection to TOR?
Many thanks for reply

comment:5 in reply to:  4 Changed 7 months ago by cypherpunks

Replying to greatormesby:

What I meant was I can access websites with any of the browsers mentioned but not with TOR.
I have tried with no anti virus software running and it is still the same

But which one is it? (Usually exiting them isn't enough)

Is this possibly something to do with Virgin Media blocking connection to TOR?

You mean https://www.virginmedia.com/? It's working for me with Tor.

Many thanks for reply

You're welcome!

comment:6 Changed 7 months ago by greatormesby

It's Kaspersky I normally use.
As for V.M. they are my ISP and I thought maybe they had started to block access to TOR because of the new government initiatives to try and stop illegal activities.
I just find it strange that I have used TOR for several years with no problems and now I suddenly get this.

comment:7 Changed 7 months ago by greatormesby

just retried and copied following two logs if they are any help.
first with bridges
4/11/2018 15:38:36 PM.000 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
4/11/2018 15:38:36 PM.000 [NOTICE] Opening Socks listener on 127.0.0.1:9150
4/11/2018 15:38:41 PM.200 [NOTICE] Bootstrapped 80%: Connecting to the Tor network
4/11/2018 15:38:41 PM.200 [NOTICE] Bootstrapped 85%: Finishing handshake with first hop
4/11/2018 15:38:44 PM.500 [NOTICE] Our directory information is no longer up-to-date enough to build circuits: We need more microdescriptors: we have 5535/6385, and can only build 59% of likely paths. (We have 85% of guards bw, 83% of midpoint bw, and 83% of exit bw = 59% of path bw.)
4/11/2018 15:38:44 PM.500 [NOTICE] I learned some more directory information, but not enough to build a circuit: We need more microdescriptors: we have 5535/6385, and can only build 59% of likely paths. (We have 85% of guards bw, 83% of midpoint bw, and 83% of exit bw = 59% of path bw.)
4/11/2018 15:38:44 PM.500 [NOTICE] We now have enough directory information to build circuits.
4/11/2018 15:38:45 PM.500 [NOTICE] Bootstrapped 90%: Establishing a Tor circuit
4/11/2018 15:38:46 PM.000 [NOTICE] Tor has successfully opened a circuit. Looks like client functionality is working.
4/11/2018 15:38:46 PM.000 [NOTICE] Bootstrapped 100%: Done
4/11/2018 15:38:47 PM.200 [NOTICE] New control connection opened from 127.0.0.1.
4/11/2018 15:38:47 PM.400 [NOTICE] New control connection opened from 127.0.0.1.
and then without bridges
4/11/2018 15:38:36 PM.000 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
4/11/2018 15:38:36 PM.000 [NOTICE] Opening Socks listener on 127.0.0.1:9150
4/11/2018 15:38:41 PM.200 [NOTICE] Bootstrapped 80%: Connecting to the Tor network
4/11/2018 15:38:41 PM.200 [NOTICE] Bootstrapped 85%: Finishing handshake with first hop
4/11/2018 15:38:44 PM.500 [NOTICE] Our directory information is no longer up-to-date enough to build circuits: We need more microdescriptors: we have 5535/6385, and can only build 59% of likely paths. (We have 85% of guards bw, 83% of midpoint bw, and 83% of exit bw = 59% of path bw.)
4/11/2018 15:38:44 PM.500 [NOTICE] I learned some more directory information, but not enough to build a circuit: We need more microdescriptors: we have 5535/6385, and can only build 59% of likely paths. (We have 85% of guards bw, 83% of midpoint bw, and 83% of exit bw = 59% of path bw.)
4/11/2018 15:38:44 PM.500 [NOTICE] We now have enough directory information to build circuits.
4/11/2018 15:38:45 PM.500 [NOTICE] Bootstrapped 90%: Establishing a Tor circuit
4/11/2018 15:38:46 PM.000 [NOTICE] Tor has successfully opened a circuit. Looks like client functionality is working.
4/11/2018 15:38:46 PM.000 [NOTICE] Bootstrapped 100%: Done
4/11/2018 15:38:47 PM.200 [NOTICE] New control connection opened from 127.0.0.1.
4/11/2018 15:38:47 PM.400 [NOTICE] New control connection opened from 127.0.0.1.
4/11/2018 15:45:26 PM.300 [NOTICE] Switching to guard context "default" (was using "bridges")

comment:8 in reply to:  6 Changed 7 months ago by cypherpunks

Resolution: duplicate
Status: needs_informationclosed

Replying to greatormesby:

It's Kaspersky I normally use.

Thanks, this confirms that it's due to Kaspersky as you can find a solution in the other ticket #25333 where a lot of people had the same problem.

comment:9 Changed 7 months ago by cypherpunks

gk, don't you want to add this almost malicious dll to WindowsDllBlocklist?

comment:10 Changed 7 months ago by greatormesby

Did not find that ticket when I looked so I apologise for that and once again many thanks for help
BTW I will use workaround while using TOR and then put settings back but will also ask Kaspersky if they have better solution

comment:11 Changed 7 months ago by greatormesby

As promised I contacted Kaspersky about this issue and thaey have confirmed it is a bug in their software which will be fixed in the next release. The release is expected in 10 Days time
Regards to all and thanks again for help

comment:12 in reply to:  11 Changed 7 months ago by cypherpunks

Replying to greatormesby:

As promised I contacted Kaspersky about this issue and thaey have confirmed it is a bug in their software which will be fixed in the next release. The release is expected in 10 Days time
Regards to all and thanks again for help

Thanks for the followup!

Note: See TracTickets for help on using tickets.