#25805 closed defect (not a bug)

Setting zoom.minPercent to 150 requires additional manual zooming

Reported by: heyjoe Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

STR:

  1. Open about:config
  2. Set zoom.minPercent to 150
  3. Open any page

EXPECTED:
The default zoom should be 150%

ACTUAL:
The default zoom remains 100%. I have to press Ctrl++ and then Ctrl+- and then the minimum zoom stays 150%. But this has to be repeated for every newly site/tab.

This is really annoying on a big 108dpi screen (everything looks way too small).

Child Tickets

Change History (5)

comment:1 Changed 10 months ago by gk

Status: newneeds_information

So, are you saying this is working in a normal Firefox and just not in Tor Browser? If so, which Firefox version have you been testing with and on which platform? Right now for me, testing on a Linux system with a vanilla Firefox 52.7.3esr the behavior is the same as you describe. Could you open an upstream bug (at https://bugzilla.mozilla.org/), so that we can get that on the radar of the Mozilla people and link to this bug in this ticket? Thanks.

comment:2 Changed 10 months ago by heyjoe

So, are you saying this is working in a normal Firefox and just not in Tor Browser?

No, I am not saying that. I don't use Firefox.

Could you open an upstream bug [...]

I don't use any Mozilla products at all, so I cannot investigate bugs on any of them. I just noticed this in TBB and reported it here.

comment:3 Changed 10 months ago by mcs

I think this is also a Firefox issue in that there is no way to set the default zoom level. Here is some more info: https://support.mozilla.org/en-US/questions/1147570

I am pretty sure that zoom.minPercent sets the lowest value to which you can change the page-specific zoom level, but does not increase the default value. You might have better luck changing layout.css.devPixelsPerPx which seems like the right thing to do to accommodate a high-dpi display. Please let us know if that works for you.

comment:4 Changed 10 months ago by heyjoe

I know about layout.css.devPixelsPerPx and I have tried it before using zoom.minPercent. Although it works the result is weird. For example setting it to 1.5 zooms all interface elements but the font of the text in the address bar, search field and bookmarks bar stays the same and as a whole the font in these fields is way too small. (Is that probably another bug which should be reported separately?) So basically it creates big elements with tiny text which is practically a waste of space for gaps. That's why, considering that UI fonts can't be scaled, I decided to use layout.css.devPixelsPerPx and at least not waste space for increasing gaps. One is basically forced to choose between two options neither of which works as expected.

Just for comparison: Testing in Chromium browser with --force-device-scale-factor works fine - everything is zoomed properly (fonts of UI included).

comment:5 Changed 10 months ago by gk

Resolution: not a bug
Status: needs_informationclosed

Okay, I think zoom.minPercent is not supposed to work as you think it is working. Thus, closing this ticket as not-a-bug. As far as I understand it layout.css.devPixelsPerPx is the pref to use. Please file a bug at Mozilla's bug tracker if you think that's broken for you. We might be able to help with that upstream bug report.

Note: See TracTickets for help on using tickets.