Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#2582 closed defect (duplicate)

Bridge Routers Broken on MAC OSX 10.6.6

Reported by: dontask Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.10-alpha
Severity: Keywords: OSX 10.6.6 Relay no running bridges known Cannot Connect No Directory Servers tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Summary: When the TOR Vidalia bundle is installed on fully updated MAC OSX 10.6.6 system, TOR does not recognize bridge routers that are manually entered in the "Settings" dialog box.

Builds tested: 0.2.1.29-0.2.10-i386-1.dmg, 0.2.2.22-alpha-0.2.10-i386.dmg

How we tested it:

1) Set up apache on my system. Friend in [country] can connect to apache and view a web page on port 80, and via https on port 443. This confirms my IP address is not blocked from the friend's network.

2) Shut down apache. Set up a TOR bridge server at same IP address. Logs show dozens of users connecting to it from all over the world. This means the system is working on my end.

3) Sent bridge server IP/port/hash to friend. When friend entered this information in TOR (see attached screen cap), their system was unable to connect to my bridge server.

4) Turned off firewall on friend's computer. Turned off IPV6. Rebooted. Problem persisted.

5) Shut down TOR on my end. Restarted Apache. Friend was able to connect to my web server on ports 80 and 443.

6) Shut down Apache. Restarted bridge router. Logs show multiple users able to connect to my bridge router.

7) We repeated this for both MAC TOR builds (stable and alpha), rebooting the system each time.

Attached:

-Screen capture
-Vidalia log file from friend's computer.

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #2583.

comment:2 Changed 7 years ago by nickm

Keywords: tor-client added

comment:3 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.