Opened 7 months ago

Closed 7 months ago

#25898 closed defect (fixed)

Youtube videos don't play automatically anymore

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability-website, TorBrowserTeam201804
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We got reports that videos on Youtube don't play anymore automatically in Tor Browser when loaded (see: https://blog.torproject.org/comment/274954#comment-274954). Rather, one has to pause them first and then start playing them.

Child Tickets

Change History (4)

comment:1 Changed 7 months ago by cypherpunks

The situation with vimeo.com is waaaaay worse ;)

(thought at first that it was a problem with my graphics driver that I had updated but seems like it's not)

Edit: I'm on Linux FWIW

Last edited 7 months ago by cypherpunks (previous) (diff)

comment:2 Changed 7 months ago by cypherpunks

FWIW this message appears sometimes:

If playback doesn't begin shortly, try restarting your device.

comment:3 Changed 7 months ago by sysrqb

Right, I noticed in this in alpha, too. This is happening because media.autoplay.enabled is now false by default, compared with that pref is true by default in the stable release. I finally looked into this now, and I believe this was caused by one of the Orfox patches.

2bcf9362c2c2820263488e3f5e9b6509da5bff2e includes setting media.autoplay.enabled = false in Orfox, however it also set this pref as false on desktop.

diff --git a/modules/libpref/init/all.js b/modules/libpref/init/all.js
index 198028eeb96c..766e665c074a 100644
--- a/modules/libpref/init/all.js
+++ b/modules/libpref/init/all.js
@@ -591,7 +591,7 @@ pref("media.encoder.webm.enabled", true);
 #endif
 
 // Whether to autostart a media element with an |autoplay| attribute
-pref("media.autoplay.enabled", true);
+pref("media.autoplay.enabled", false);

I partly prefer disabling autoplay, but the UX is not good, and this wasn't an intentional change on desktop, so I think we should revert this. media.autoplay.enabled is set as false in the mobile-specific pref file (mobile.js), already - so changing modules/libpref/init/all.js shouldn't affect Orfox.

comment:4 Changed 7 months ago by gk

Keywords: TorBrowserTeam201804 added
Resolution: fixed
Status: newclosed

Nice find! And glad we caught that one in the alpha. I pushed a fixup commit (commit 7814f97385daa7b5056bfaabe6ca56206acd6b58) to tor-browser-52.7.3esr-8.0-1.

Note: See TracTickets for help on using tickets.