Opened 8 months ago

Closed 8 months ago

#26001 closed defect (duplicate)

Windows build of tor is failing

Reported by: boklm Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Our nightly build of Tor Browser is failing when building tor for Windows (on i686 and x86_64, using mingw-w64). We have this in the logs:

  CC       src/common/tortls.o
  CC       src/common/crypto_curve25519.o
  CC       src/common/crypto_ed25519.o
  CC       src/common/compat_libevent.o
src/common/tortls.c: In function 'tor_tls_create_certificate':
src/common/tortls.c:515:21: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
   if (cert_lifetime <= min_real_lifetime + start_granularity) {
                     ^~
  CC       src/common/procmon.o
  CC       src/common/timers.o
  CC       src/common/src_common_libor_testing_a-address.o
  CC       src/common/src_common_libor_testing_a-address_set.o
  CC       src/common/src_common_libor_testing_a-backtrace.o
  CC       src/common/src_common_libor_testing_a-buffers.o
  CC       src/common/src_common_libor_testing_a-compat.o
  CC       src/common/src_common_libor_testing_a-compat_threads.o
  CC       src/common/src_common_libor_testing_a-compat_time.o
  CC       src/common/src_common_libor_testing_a-confline.o
  CC       src/common/src_common_libor_testing_a-container.o
src/common/compat_time.c: In function 'monotime_coarse_diff_msec32_':
src/common/compat_time.c:634:1: error: expected ';' before '}' token
 }
 ^
Makefile:6263: recipe for target 'src/common/src_common_libor_testing_a-compat_time.o' failed
make[1]: *** [src/common/src_common_libor_testing_a-compat_time.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory '/var/tmp/build/tor-master'
Makefile:3336: recipe for target 'all' failed
make: *** [all] Error 2

It looks like it fails in code added in commit 9abf541f7f70068b6f7567481739ca6374f1fd57.

Child Tickets

Change History (1)

comment:1 Changed 8 months ago by boklm

Resolution: duplicate
Status: newclosed

Ah, this is a duplicate of #26000.

Note: See TracTickets for help on using tickets.