#26005 closed defect (fixed)

OpenSSL-nodep fixes seem to have broken LibreSSL

Reported by: nickm Owned by: nickm
Priority: High Milestone: Tor: 0.3.4.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 034-must regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: asn Sponsor:

Child Tickets

Change History (9)

comment:1 Changed 20 months ago by nickm

I just tried building with Tor master and libressl 2.7.2. While doing so, I found some compilation warnings (#26006), but not the ones reported on the gentoo bugtracker.

Anybody have suggestions for how I can reproduce this?

comment:2 Changed 19 months ago by toralf

Gentoo stable is at 2.6.4, the 2.7.x needs more testing/work in Gentoo land - maybe that explains the different compile issues.

Last edited 19 months ago by toralf (previous) (diff)

comment:3 Changed 19 months ago by nickm

Okay, I do see these warnings this with libressl-2.6.4.

comment:4 Changed 19 months ago by nickm

Status: newneeds_review

Fix in my branch bug26005_034; please review and test along with the fix for #26006, which fixes a couple of warnings.

comment:5 Changed 19 months ago by nickm

Owner: set to nickm
Status: needs_reviewaccepted

setting owner

comment:6 Changed 19 months ago by nickm

Status: acceptedneeds_review

comment:7 Changed 19 months ago by dgoulet

Reviewer: asn

comment:8 Changed 19 months ago by asn

Status: needs_reviewmerge_ready

Yep, I can verify that with the branch from comment:4, tor builds with libressl-2.6.4 (altho emits the warnings from #26006)! LGTM!

comment:9 Changed 19 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

Okay; merging!

Note: See TracTickets for help on using tickets.