Opened 19 months ago

Last modified 4 months ago

#26020 needs_information defect

pdf.js doesn't work on highest security settings because of JS disabled

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Isn't PDF.js a privileged part of browser?

Child Tickets

Change History (4)

comment:1 Changed 19 months ago by cypherpunks

Status: newneeds_information

You'd have to be more specific, as it's working for me...

comment:2 Changed 19 months ago by cypherpunks

Resolution: worksforme
Status: needs_informationclosed

I guess you had a PDF embedded in an iframe in which case it won't work, why? Because NoScript. You can right click > Open frame in new tab if you want it to work though.

Setting as worksforme as what I said above is almost certainly true.

comment:3 Changed 4 months ago by cypherpunks

Resolution: worksforme
Status: closedreopened

I confirm that it doesn't work. Highest security level sets javascript.enabled into false. This breaks everything opening in a tab that is written in JS, including pdf.js.

comment:4 in reply to:  3 Changed 4 months ago by gk

Status: reopenedneeds_information

Replying to cypherpunks:

I confirm that it doesn't work. Highest security level sets javascript.enabled into false. This breaks everything opening in a tab that is written in JS, including pdf.js.

How did you confirm that? How can we reproduce this bug?

Note: See TracTickets for help on using tickets.