Opened 4 months ago

Last modified 3 months ago

#26030 new enhancement

Delete "Tor Messenger downloads and updates" section

Reported by: cypherpunks Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Child Tickets

TicketTypeStatusOwnerSummary
#26046enhancementclosedmetrics-teamAdd text to the Tor Messenger downloads page to explain it is no longer developed
#26047tasknewmetrics-teamCreate a static summary of the Tor Messenger statistics

Change History (13)

comment:1 Changed 4 months ago by irl

Resolution: not a bug
Status: assignedclosed

Historical information may still be of interest, and you'll notice also that we are still receiving update pings.

We may want to update the text under the graph to explain that it's no longer actively developed, but that would be a different ticket.

comment:2 Changed 4 months ago by karsten

Resolution: not a bug
Status: closedreopened

I agree with irl that we shouldn't remove the graph right away.

But we're not going to keep the graph forever. Maybe we can brainstorm here what would be a good time to remove it. 3 months from now? 6 months? 12?

And does anybody want to open a new ticket for that updated graph text mentioning the sunsetting of Tor Messenger?

comment:3 Changed 4 months ago by irl

I feel that even 12 months would be too soon, unless we had a plan to replace it with some sort of static view of the history of Tor Messenger during its life.

comment:4 Changed 4 months ago by irl

Oooh. A thought: We put this static analysis alongside the reports from the Analysis tickets on the website that we discussed at the Aberdeen meeting.

comment:5 in reply to:  4 Changed 4 months ago by karsten

Replying to irl:

Oooh. A thought: We put this static analysis alongside the reports from the Analysis tickets on the website that we discussed at the Aberdeen meeting.

Sure, sounds good to me. And maybe it will take a sufficient number of months for us to set up that page that we can remove the (dynamic) graph at the same time as adding a static version of it to the new page.

FWIW, this specific graph requires very little maintenance effort as compared to other graphs. It would also be perfectly fine to keep it for longer than 12 months.

So, what are the next steps here?

  • Open a new ticket for that updated graph text mentioning the ​sunsetting of Tor Messenger.
  • Revisit this ticket when there's a page for Analysis tickets.

comment:6 Changed 4 months ago by irl

Type: defectenhancement

I have opened #26047 to produce the static analysis, and #26046 to update the text on the current webpage for now.

comment:7 Changed 3 months ago by karsten

Status: reopenedneeds_information

Thanks for opening those two tickets. Do we need to keep this ticket open? If not, can you close it? If yes, can you include a short summary what we need to do and when? Thanks!

comment:8 Changed 3 months ago by karsten

Ah, those other two tickets are child tickets. Just seeing that now. Hmmm...

comment:9 Changed 3 months ago by karsten

So, we might be able to resolve #26046 shortly, but it probably makes more sense to produce the static analysis just before we take the graph offline. Just saying, once #26046 is resolved, this ticket is not actionable anymore.

comment:10 Changed 3 months ago by irl

Status: needs_informationnew

The ticket would be blocked by the remaining child ticket, but I think we should still keep this ticket open in case anybody would like to object, with some reasons we haven't thought of, to the removal of the page.

Producing the final analysis is independent of that analysis being published, so these tasks shouldn't block on each other and should be done when it's easiest to do. This means there could be a gap between the final analysis being written and it being published.

comment:11 Changed 3 months ago by karsten

Sounds good! I'll also ping the Tor Messenger developers and inform them of this ticket.

comment:12 Changed 3 months ago by sukhbir

Hi. (Speaking for myself and not the team) I think #26047 addresses the only thing I had in mind. I don't think we need the graph up for longer than 12 months but I leave that decision to you since you mentioned it doesn't require much maintenance.

Thanks for working on this.

comment:13 Changed 3 months ago by boklm

If in 12 months the number of pings is very small, I think we don't need to keep it longer. However if the number of pings did not decrease a lot, it might be interesting to keep it longer to see how it evolves.

Note: See TracTickets for help on using tickets.