#26031 closed defect (fixed)

suspected bug in exit_addresses - no IPv6 addresses?

Reported by: cypherpunks Owned by: metrics-team
Priority: Low Milestone:
Component: Metrics/Onionoo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It is strange that there is not a single IPv6 adresses in exit_addresses even for IPv6 exiting relays like https://metrics.torproject.org/rs.html#details/F98CE40031795D3704365019EA9F8AC56AE2994B

"
Array of IPv4 or IPv6 addresses that the relay used to exit to the Internet in the past 24 hours. IPv6 hex characters are all lower-case. Omitted if array is empty. Changed on April 17, 2018 to include all exit addresses, regardless of whether they are used as onion-routing addresses or not.
"

Does the exit scanner explicitly try to connect to IPv6 destination IPs to collect IPv6 exit_addresses?

Child Tickets

Change History (5)

comment:1 Changed 14 months ago by cypherpunks

Status: newneeds_review

somewhat a duplicate of #16947

to fix the onionoo side of this:

remove "or IPv6" from the exit_addresses field description until #16947 is fixed

comment:2 Changed 14 months ago by karsten

I think you have a point here. The exit scanner never included IPv6 addresses in its scan results, so this looks like a documentation bug in Onionoo. Suggested documentation change:

"Array of IPv4 or IPv6 addresses that the relay used to exit to the Internet in the past 24 hours. IPv6 hex characters are all lower-case. Omitted if array is empty. Changed on April 17, 2018 to include all exit addresses, regardless of whether they are used as onion-routing addresses or not."

When the exit scanner or another tool starts including IPv6 addresses in scan results we can revert this change, probably accompanied by a minor protocol version bump.

Needs review by another metrics team person.

comment:3 Changed 14 months ago by karsten

Priority: MediumLow

comment:4 Changed 13 months ago by iwakeh

Status: needs_reviewmerge_ready

Suggested change makes sense.

comment:5 Changed 13 months ago by karsten

Resolution: fixed
Status: merge_readyclosed

Thanks! Merged and deployed. Closing.

Note: See TracTickets for help on using tickets.